submit control doesnt work in xul

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: surkov, Assigned: surkov)

Tracking

(Depends on: 1 bug, {fixed1.8.0.4, fixed1.8.1})

Trunk
x86
Windows 2000
fixed1.8.0.4, fixed1.8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

794 bytes, patch
Allan Beaufour
: review+
smaug
: review+
Details | Diff | Splinter Review
(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051212 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051212 Firefox/1.6a1

After patch applying of bug 307627 xforms:submit element doesnt work still. The problem is the xul:button element doesn't fire DOMActivate event. I guess it should (bug 323005).

Reproducible: Always
(Assignee)

Updated

13 years ago
Depends on: 323005
(Assignee)

Comment 1

13 years ago
I guess xforms controls for xul should fire 'DOMActivate' unless xul:button it do. If the bug 323005 will be confirmed and fixed then the corresponding code should be removed. Threafore I mark as dublicate of 323850.

*** This bug has been marked as a duplicate of 323850 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Updated

12 years ago
Assignee: aaronr → surkov
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

12 years ago
Created attachment 215204 [details] [diff] [review]
patch

a little misspelling :)
Attachment #215204 - Flags: review?(allan)
(Assignee)

Updated

12 years ago
Attachment #215204 - Flags: review?(smaug)
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED

Updated

12 years ago
Attachment #215204 - Flags: review?(smaug) → review+

Updated

12 years ago
Attachment #215204 - Flags: review?(allan) → review+

Comment 3

12 years ago
Checked into trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch

Updated

12 years ago
Blocks: 332853

Updated

12 years ago
Keywords: fixed1.8.0.3, fixed1.8.1

Updated

12 years ago
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.