Closed Bug 32312 Opened 21 years ago Closed 21 years ago

Can't delete from second imap mail window

Categories

(MailNews Core :: Backend, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: akkzilla, Assigned: scottputterman)

Details

I have one 3-pane window open on my inbox.  I use "move to trash" deletion.
I double-click on another folder on the same imap server to bring up another
window,
click on inbox back in the first window to go back there,
collapse both of the folder panes,
go to the second window, highlight a message or a group of messages and press
delete.

On stdout I see
tree is valid
and if I had multiple messages selected, the selection goes away; but nothing is
deleted.

Delete still works fine in the first window, pointing at my inbox.
This is working for me.  Are you sure this isn't 24456 and it just hit you the
first time in the new window?  Does this happen on the first try if you do it again?
I don't understand bug 24456 well enough to say whether this is the same thing
or not.  24456 seems to deal mostly with the last message in a folder, whereas
what I'm seeing happens regardless of which message I try to delete.

Other weirdnesses I'm seeing:
1. If I try to delete in this folder with the Delete key rather than clicking on
delete, I get into a state where back in this browser window I can no longer
type into the Additional Comments field (this is the third type I've started
this reply, due to that problem).
2. I can still delete just fine in my Inbox back in the first window.
3. At some point, I closed the window, then opened another one on the folder and
it turned out that some of the messages had in fact been deleted, even though it
hadn't shown me that while I was doing the deletions.  But I haven't been able
to reproduce that; now I'm back to none of my deletes "taking".
4.. If I close the second window and load the problem folder back in the first
window, now I can't delete there either.  So this is tied to the folder, not to
the window.

24456, or not?
I'm not sure about the Additional Comments field bug, but even though 24456 was
reported on the last message I think that's just because he's always deleting
from the bottom.  I've reproduced the problem where after deleting between 0 and
50 times, delete no longer works, before I ever started coding multiple windows.
I see this even on the first delete after I've brought up the new window.
Still, it wouldn't surprise me if they're the same bug, or at least closely
related.  The textarea bug may or may not be related, but let's not worry about
it 'til the delete issues are fixed.
QA Contact: lchiang → laurel
I think this still may be related to other deleting bugs.  Hopefully if those 
ever get fixed, this will go away.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
I'm marking WORKSFORME.  Akkana, could you verify this.  I think the delete bugs 
have been fixed for a while.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
This seems to be working ok for me with jul6 commercial build linux rh6.0.
I'm going to mark verified, since Akkana hasn't commented recently. We can
always reopen if deemed necessary.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.