Closed Bug 323222 Opened 15 years ago Closed 14 years ago

Line not drawn to arc() if no preceded by drawing or moveTo()

Categories

(Core :: Canvas: 2D, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 296763

People

(Reporter: web, Unassigned)

References

()

Details

Attachments

(1 file)

According to the arc() definition, "The [arc] start point is added to the list of points of the subpath and the current position is joined to that point by a straight line."

Firefox 1.5 does not follow this rule unless there is drawing or an explicit moveTo() prior to the arc().  This should not be necessary, as according to the definition of beginPath() a) "When the context is created, a call to beginPath() is implied," and b) "The beginPath() method resets the list of subpaths to an empty list, and calls moveTo() with the point (0,0)."
Attached file Test case
Blocks: 323999

*** This bug has been marked as a duplicate of 296763 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.