Firefox reports CSS errors to the JavaScript console (and shouldn't)

RESOLVED DUPLICATE of bug 319764

Status

Toolkit Graveyard
Error Console
RESOLVED DUPLICATE of bug 319764
12 years ago
11 months ago

People

(Reporter: James Edwards, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Opera/8.5 (Macintosh; PPC Mac OS X; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 

CSS is not JavaScript, and CSS errors should not be in the JavaScript console. Although this is a very useful feature, it's in the wrong place; there should be either a separate pane in the console, separate from errors and warnings, or (better) an entirely separate console.

The real problem with it as it is, is that it's clutter for JS developers - it gets in the way of programming information. 

It's also semi-counter-productive in that not everything it reports as an error actually is an error - it reports any unknown or proprietary syntax outside its own vocab (such as the CSS3 'border-radious' in the demo URL); I suppose that can't be helped, but it's another reason why the reports should be shelved somewhere else other than the JS console - some kind of CSS console.

Reproducible: Always

Steps to Reproduce:
1. View any page using CSS which is not supported in Firefox
2.
3.

Actual Results:  
Errors are shown in the JS console

Expected Results:  
Errors should not be shown in the JS console

Shown the errors somewhere else (or not at all)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 319764 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

11 months ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.