JS warning opening MailNews / selecting folders

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

(4 keywords)

1.8 Branch
fixed-seamonkey1.0, fixed-seamonkey1.1a, fixed1.8.0.1, fixed1.8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.32 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
Opening MailNews produces a  warning in the JS console, same warning occurs everytime you select a folder in the folder pane:

"Warning: reference to undefined property nsMsgViewType.eSearch
Source File: chrome://messenger/content/commandglue.js
Line: 684"

This does not happen on trunk builds.

Karsten/Neil, iirc you know about this (and the cause)? Dupe away if this is already filed ;)

Comment 1

11 years ago
I forgot the review comment to bug 241212 when checking into the branches :-[
(Assignee)

Updated

11 years ago
Depends on: 241212
(Assignee)

Comment 2

11 years ago
Created attachment 208580 [details] [diff] [review]
1.8.0 patch

OK, this should fix the warning (eSearch --> eShowSearch).
Assignee: mail → stefanh
Status: NEW → ASSIGNED
Attachment #208580 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #208580 - Flags: review?(neil.parkwaycc.co.uk)

Comment 3

11 years ago
Comment on attachment 208580 [details] [diff] [review]
1.8.0 patch

Although seeing as I did get it right on the trunk I should be able to check this in on the branches with the original r/sr/as.
Attachment #208580 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #208580 - Flags: superreview+
Attachment #208580 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #208580 - Flags: review+
(Assignee)

Updated

11 years ago
Blocks: 323357

Comment 4

11 years ago
Don't forget this can go on the 1.8 branch as well Stefan.

Updated

11 years ago
Attachment #208580 - Flags: approval-seamonkey1.1+
(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> Don't forget this can go on the 1.8 branch as well Stefan.

I think Neil ment that the patch already has approval on both branches, since the original patch was approved.

Comment 6

11 years ago
Fix checked in on both branches. Do we need flags for this?
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 7

11 years ago
adding chunks of flaggy goodness
Keywords: fixed1.8.0.1, fixed1.8.1

Updated

11 years ago
Whiteboard: fixed-seamonkey1.0
Keywords: fixed-seamonkey1.0
Whiteboard: fixed-seamonkey1.0

Updated

11 years ago
Keywords: fixed-seamonkey1.1a
You need to log in before you can comment on or make changes to this bug.