History autocomplete doesn't autocomplete "fi" to "file://" URIs correctly

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: bzbarsky, Assigned: ajschult784)

Tracking

({fixed1.8.1, regression})

Trunk
fixed1.8.1, regression
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
BUILD: Current trunk debug build

STEPS TO REPRODUCE:
1) Start Firefox with a clean profile.
2) Say that you don't want it to be the default browser
3) Wait for the start page to load.
4) Hit Ctrl-L on your keyboard.
5) Type "file:///home/bzbarsky/test.html" in the URL bar and hit enter.
6) Wait for the HTML to load.
7) Hit Ctrl-L on your keyboard.
8) Type "fi" in the URL bar.  At this point the autocomplete dropdown appears.
   It contains one entry in it.
9) Hit the down arrow key once.
10) Hit the right arrow key once.
11) Hit the left arrow key twice.
12) Hit the backspace key twice.
13) Type the letter "x".
14) Hit enter.

EXPECTED RESULTS:

After step 9 the URL bar contains the string "file:///home/bzbarsky/test.html" and the caret is at the _end_ of the string.  After step 13 the URL bar contains the string "file:///home/bzbarsky/test.xml".  After step 14 the XML file loads.

ACTUAL RESULTS:

After step 9 the URL bar contains the string "fi" and the caret is at the _beginning_ of the string.  After step 13 the URL bar contains the string "xfi".  Step 14 gives an error page.

This looks like a likely regression from bug 202992.  Could someone check on that, please?
(Reporter)

Updated

13 years ago
Flags: blocking-firefox2?
Indeed, this is a regression from bug 202992.
OS: Linux → All
Hardware: PC → All

Updated

13 years ago
Flags: blocking-firefox2? → blocking-firefox2+
(Assignee)

Comment 2

13 years ago
Why not just fill in the URL bar with the whole URL (rather than append the last part of it)?  The patch to do that is trivial.
(Assignee)

Comment 3

13 years ago
Created attachment 208829 [details] [diff] [review]
patch

This backs out the patch from bug 323549 and sets the textbox string to the result string.

This also handles the URL prefixes (www and ftp), as well as anything else an autocomplete result provider might throw at it (like names/email addresses)
Assignee: nobody → ajschult
Status: NEW → ASSIGNED
Attachment #208829 - Flags: review?
(Assignee)

Updated

13 years ago
Attachment #208829 - Flags: review? → review?(mconnor)
Comment on attachment 208829 [details] [diff] [review]
patch

Much better, thanks!
Attachment #208829 - Flags: review?(mconnor)
Attachment #208829 - Flags: review+
Attachment #208829 - Flags: approval1.8.1+
(Assignee)

Comment 5

13 years ago
FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.