Last Comment Bug 323562 - Should find Xrender, freetype2, fontconfig using pkg-config
: Should find Xrender, freetype2, fontconfig using pkg-config
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Christian :Biesinger (don't email me, ping me on IRC)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-15 15:44 PST by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2014-04-25 15:15 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mozbug-323562-proper-ext-libs-check.patch (775 bytes, patch)
2007-05-30 12:09 PDT, Priit Laes
no flags Details | Diff | Splinter Review

Description Christian :Biesinger (don't email me, ping me on IRC) 2006-01-15 15:44:25 PST
(compare bug 323551)

Currently, configure.in adds a hardcoded list of libraries for fontconfig, freetype and xrender:
               MOZ_CAIRO_LIBS="$MOZ_CAIRO_LIBS $XLDFLAGS -lXrender -lfreetype -lfontconfig"

It should use pkg-config for that.
Comment 1 Masaki Katakai 2006-03-16 05:23:27 PST
I'm using Solaris for the build. Because of this bug, it always fails. I have to add "-L/usr/sfw/lib" to MOZ_CAIRO_LIBS.
Comment 2 Priit Laes 2007-05-30 12:09:25 PDT
Created attachment 266645 [details] [diff] [review]
mozbug-323562-proper-ext-libs-check.patch

Added pkg-config checks for required libs for in-tree cairo
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-10-07 08:00:01 PDT
This has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.