Closed Bug 32363 Opened 25 years ago Closed 24 years ago

We need virtual keys for every key on the keyboard!

Categories

(Core :: Layout, defect, P3)

x86
Windows 95
defect

Tracking

()

VERIFIED DUPLICATE of bug 17008

People

(Reporter: dan6992, Assigned: joki)

Details

I know the most recent version of the DOM2 spec removed the key events section, 
but we still need VK values for most of the keys. These are needed to properly 
impliment hot keys in XUL documents. For example I am currently working on an 
imagemap editor for composer and want to impliment PhotoShop style zoom 
keys (Ctrl+ zooms in, Ctrl- zooms out), however I can't because the VK_PLUS and 
VK_MINUS keys are not implimented. I know I could create this effect using 
JavaScript but then it would defete the whole purpose of using broadcasters to 
disable/enable functions.
Reassigning to Joki
Assignee: troy → joki
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dan, would it be possible for you to create a list of the keys that are 
currently lacking virtual keys? We'd appreciate the help!
Duping on 17008

*** This bug has been marked as a duplicate of 17008 ***
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.