Closed Bug 323795 Opened 15 years ago Closed 14 years ago

Height of minimonth/agenda-tree sidebar should persist

Categories

(Calendar :: Lightning Only, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: BesTo, Assigned: ssitter)

References

Details

(Whiteboard: [good first bug])

Attachments

(1 file)

Hey.

For me its really annoying to resize lightning after every startup.
Lightning should save the resized sidebar-position between sessions.

Thx in advance. ;-)
Just for clarification: Using todays Lightning branch build with Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8) Gecko/20051201 Thunderbird/1.5 the 'width' of sidebar is remembered but not the 'height'. You meant that?
Confirming the issue about the height of the minimonth/agenda-tree not being persisted.  This bothers me too.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: lightning should save resized sidbar-position → Height of minimonth/agenda-tree sidebar should persist
Whiteboard: [good first bug]
Lightning team: You guys aren't really going to complete 0.1 without sorting this issue are you. It's a minor bug in the scheme of things but it's one that's highly visible. There would be much more favourable reviews of your work if you didn't have this one lying around.

In fact it's the only bug I experience in lightning at the moment on a day to day basis. Everything else is just an incomplete feature or something else I'm happy to wait for progress on.

I've only done a bit of XUL so I could be wrong but would this not just take 1 hour or less from someone familiar with tb+ligthning ui code? Please fix!
*** Bug 330329 has been marked as a duplicate of this bug. ***
(In reply to comment #3)
> I've only done a bit of XUL so I could be wrong but would this not just take 1
> hour or less from someone familiar with tb+ligthning ui code? Please fix!
> 

Hm, I don't think that it is that easy. The size of the panes (or at least of one pane) or the location of the splitter has to be stored somewhere (I guess in localstore.rdf). I'm unfortunately not familiar with the architecture, but this might also be a Thunderbird issue (e.g. if you want to store the height of the folder pane; however, currently the width of the folderpanebox is stored). Thus, in my view, it is a little bit more than just adding a persist attribute. However, guessing time fo such changes is a little bit like gambling.
The trick is to add id's so that height can be persist. 350 pixel is just the initial height after first installation.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #214925 - Flags: first-review?(dmose)
(In reply to comment #6)
> The trick is to add id's so that height can be persist. 350 pixel is just the
> initial height after first installation.

Yes, with id it works. It looks easier as I guessed and the height is added automatically to the localstore.rdf. Nice fix, thank you, also for the explanation. 
Comment on attachment 214925 [details] [diff] [review]
persistent height for everyone

r=dmose
Attachment #214925 - Flags: first-review?(dmose) → first-review+
Thanks for the patch, Stefan!  I added your name/email addr to the license boilerplate before checking in.  Sorry it took me so long to get to this.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
*** Bug 335677 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.