Link border colors around images

VERIFIED FIXED in M5

Status

()

Core
CSS Parsing and Computation
P2
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: Peter Linss)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I think link border colors that are drawn around images should change with the
link color, unless they are explicitly specified differently.

This can be done easily in ua.css, since border-color, if not specified,
"inherits" from color.  Thus you could change the four a:link img, a:visited
img, etc. from (for the a:link img example)

border: 2px solid blue;

to

border-width: 2px;
border-style: solid;

and leave the color to "inherit" from color.
(Reporter)

Comment 1

19 years ago
You could actually just set

border: 2px solid

now that I remember the shorthand property doesn't need all parts...
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Thanks, good catch!
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

19 years ago
Verified fixed.
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 4

19 years ago
Reopening bug.  This is still a problem for a:visited, a:active, and a:out-of-
date (although I think it was once fixed).
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

19 years ago
The problem is that the style changes aren't causing child frames to redraw
outside the frame of the parent, so the image border only updates inside the
line frame. This was exposed either by improvements in targeting style changes
or changes to line height calculations.
(Assignee)

Updated

19 years ago
Target Milestone: M5
(Reporter)

Comment 6

19 years ago
Are you talking about bug 5407 rather than this one?
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

19 years ago
No, I was talking about the behavior I saw on this one. This works for me except
for the repaint issue. I'm closing this as a dup of 5407 now.

*** This bug has been marked as a duplicate of 5407 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

19 years ago
As I said when I reopened it, it is fixed for a:link.  However, it is not fixed
for a:active.  I can tell this in two ways:

1) Going to the above URL, and clicking and holding down the mouse over the
image.  The bottom bit of the border turns lime.  It should be the same shade
of green as it is with the mouse out of the area, since the test page
sets :active to green.

2) Reading ua.css, which is how I found the problem in the first place (both
times).  This shows that it is a problem still for :active, :visited, and :out-
of-date (the latter two are not hooked up yet).

Thus you should change the following lines in ua.css from:

213 a:visited img {
214   display: inline;
215   border: 2px solid purple;
216   text-decoration: none;
217 }
218 a:active img {
219   display: inline;
220   border: 2px solid lime;
221   text-decoration: none;
222 }
223 a:out-of-date img {
224   display: inline;
225   border: 2px solid red;
226   text-decoration: none;

to:

213 a:visited img {
214   display: inline;
!215   border: 2px solid;
216   text-decoration: none;
217 }
218 a:active img {
219   display: inline;
!220   border: 2px solid;
221   text-decoration: none;
222 }
223 a:out-of-date img {
224   display: inline;
!225   border: 2px solid;
226   text-decoration: none;

Reopening bug again.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
Verified fixed.
You need to log in before you can comment on or make changes to this bug.