When getting focus, link text is wrapped and link is not followed

RESOLVED DUPLICATE of bug 292534

Status

()

--
minor
RESOLVED DUPLICATE of bug 292534
13 years ago
13 years ago

People

(Reporter: fippu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8) Gecko/20060110 Debian/1.5.dfsg-4 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8) Gecko/20060110 Debian/1.5.dfsg-4 Firefox/1.5

When a link receives focus (by click or TAB), there sometimes is a strange word wrapping, causing the link text to be less large. If you click on the right zone of the text, there won't be no text anymore, so the link will not be followed and you have to click a second time.

When clicking on the left, the wrapping occurs, but as there remains some text under the mouse pointer, you do not have to reclick. In this case, it is just a rendering error.

This does not happen with every link, I often see it on web discussion boards.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to the page mentioned above (Heise Newsticker, discussion board).
2a. Click on a followup in the thread-view -or-
2b. Choose a followup with the TAB key
3. See how the text is wrapped around and moves out of your mouse pointer's reach.

Actual Results:  
The link's text re-wraps and might move out of the mouse pointer's reach.

Expected Results:  
The text wrapping should change, unless e.g. the CSS defines special formats for focused links that would change its width.

None
(Reporter)

Comment 1

13 years ago
Please see also:
#250527 and #310407. Sorry, seems I always find similar bugs *after* having filed one.

Comment 2

13 years ago
Duplicate of (Suite bug 301355 ->) Core bug 292534?
Definitely a duplicate.

*** This bug has been marked as a duplicate of 292534 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.