Userdefined tags can lose one of their attributes

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
HTML: Parser
P4
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: mrbkap, Assigned: mrbkap)

Tracking

Trunk
mozilla1.9alpha1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch], URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

12 years ago
Userdefined tags get a special __moz-userdefined attributed pushed onto them so that editor can easily identify them. The implementation of this tag, however, can cause us to lose one of the other attributes if the tag is misplaced. I have a patch that fixes this.
(Assignee)

Comment 1

12 years ago
Note: there's also some cleanup I want to do.
Status: NEW → ASSIGNED
Priority: -- → P4
Whiteboard: [patch]
(Assignee)

Comment 2

12 years ago
Created attachment 209145 [details] [diff] [review]
Fix
Attachment #209145 - Flags: superreview?(jst)
Attachment #209145 - Flags: review?(bugmail)
(Assignee)

Comment 3

12 years ago
Comment on attachment 209145 [details] [diff] [review]
Fix

This is the wrong patch (even for the cleanup) :(
Attachment #209145 - Attachment is obsolete: true
Attachment #209145 - Flags: superreview?(jst)
Attachment #209145 - Flags: review?(bugmail)
(Assignee)

Comment 4

12 years ago
Created attachment 209146 [details] [diff] [review]
Fix
Attachment #209146 - Flags: superreview?(jst)
Attachment #209146 - Flags: review?(bugmail)
Comment on attachment 209146 [details] [diff] [review]
Fix

parser sucks
Attachment #209146 - Flags: review?(bugmail) → review+
Comment on attachment 209146 [details] [diff] [review]
Fix

sr=bzbarsky; sicking's right.
Attachment #209146 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 7

12 years ago
Comment on attachment 209146 [details] [diff] [review]
Fix

Checked in.
Attachment #209146 - Attachment is obsolete: true
(Assignee)

Comment 8

12 years ago
Created attachment 209155 [details] [diff] [review]
Cleanup

This consolidates a duplicated block and (I think) fixes this bug independently of the previous patch. It also turns an if (...) if (...) into an if (...) else if (...) to avoid potential problems if the element table was tweaked incorrectly (such that an element had kSaveMisplaced _and_ kBadContentWatch set on it). I also got rid of a redundant if (aToken) check (if someone wants, I'll prove that it's redundant!). I'll attach a diff -w for easier viewing in a second.
Attachment #209155 - Flags: superreview?(jst)
Attachment #209155 - Flags: review?(bugmail)
(Assignee)

Comment 9

12 years ago
Created attachment 209156 [details] [diff] [review]
Cleanup -w
Comment on attachment 209155 [details] [diff] [review]
Cleanup

sr=jst
Attachment #209155 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 11

12 years ago
Everything's been checked into the trunk. You guys are hard on the parser :-(.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

12 years ago
*** Bug 348832 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.