SVG renderer does not handle bidi text (urdu)

RESOLVED DUPLICATE of bug 311545

Status

()

RESOLVED DUPLICATE of bug 311545
13 years ago
13 years ago

People

(Reporter: jessbody, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Under Linux, the Urdu (Arabic) text in SVG does not appear RTL and the characters are not joined. The text characters appear LTR (and not joined). Whatever fonts are selected, the problem remains. On Windows XP, FF does display the Urdu text in SVG correctly (RTL and characters joined).

Reproducible: Always

Steps to Reproduce:
1. View a SVG file containing Urdu text with FF under Linux, e.g.,
http://geocities.com/urdutext/dial1.xml
In the example, the Urdu text is at the bottom. You can change the fonts in the <text> field to whatever are installed on the system, e.g., clearlyU, Tahoma.

Actual Results:  
The Urdu text appears LTR instead of RTL, and the characters are not joined. The problem stays whatever fonts are specified in the <text> field.

Expected Results:  
The Urdu text should appear RTL with the characters joined. For correct results view the SVG file with FF under windows XP.

Handle BIDI correctly in SVG.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 311545 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.