browser.tabs.tabClipWidth does not immediately affect first tab when second tab is opened

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED WORKSFORME
13 years ago
a year ago

People

(Reporter: Uriah Narmed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060121 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060121 Firefox/1.6a1

When browser.tabs.tabClipWidth is less than the default/maximum tab width (i.e., less than 250) and a new tab is opened (causing both to shrink to less than 250px wide), the first tab ignores browser.tabs.tabClipWidth and always displays the close tab button.

Reproducible: Always

Steps to Reproduce:
1. Set browser.tabs.tabClipWidth to 249 and verify that browser.tabs.autoHide is false.
2. Size a new browser window to <500 pixels wide
3. Open a new tab (for a total of two open tabs)

Actual Results:  
Both tabs display the close tab button

Expected Results:  
Only the new tab should display the close tab button

As soon as the original tab is focused or the window is resized, the browser seems to "remember" and applies the browser.tabs.tabClipWidth setting.

Updated

13 years ago
Blocks: 308396

Comment 1

13 years ago
*** Bug 327929 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

12 years ago
This appears to be fixed in RC3. (It was probably fixed long before then, but I haven't tested since filing this bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 3

12 years ago
->WORKSFORME since we can't pinpoint what patch fixed this.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.