Closed Bug 324286 Opened 14 years ago Closed 14 years ago

Create task/event via double-click does not work

Categories

(Calendar :: Sunbird Only, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

(Keywords: regression)

Attachments

(1 file)

Create task/event via double-click does not work anymore. 
Regression from Bug 296893.

Error: newEventCommand is not defined
Source File: chrome://calendar/content/calendarWindow.js
Line: 68

Error: newToDoCommand is not defined
Source File: chrome://calendar/content/unifinderToDo.js
Line: 220
Attached patch patchSplinter Review
I had to rename variable newEvent too, because otherwise I get the error "newEvent is not a function".

Quoting from http://www.crockford.com/jslint/lint.html:
> In JavaScript, blocks do not introduce a scope. There is only function-scope.
> JavaScript's blocks confuse experienced programmers and lead to errors.

True, true.
Assignee: mostafah → ssitter
Status: NEW → ASSIGNED
Attachment #209237 - Flags: first-review?(jminta)
Comment on attachment 209237 [details] [diff] [review]
patch

Thanks for this.  r=jminta
Attachment #209237 - Flags: first-review?(jminta) → first-review+
patch checked in.  Glad to have this fixed so fast, stefan, thanks.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060909 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.