Typing Alt + 0173 into search box crashes Firefox 1.5

RESOLVED DUPLICATE of bug 319914

Status

()

RESOLVED DUPLICATE of bug 319914
13 years ago
13 years ago

People

(Reporter: mail, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5

When using Google I sometimes use Alt + ASCII characters to insert accented letters. I accidently inserted Alt + 0173 which crashed the browser. I asked a couple of friends to try this, they had the same problem. I think this may apply to any typing field in the browser - possibly a form manager bug.

Reproducible: Always

Steps to Reproduce:
1.Open Google
2.Hold down left Alt key and type 0173 on numeric keypad.
3.

Actual Results:  
Browser crashes, all open browser windows are closed and the Windows 'Report Error' pop-up appears. This doesn't happen with 1.0.7

Expected Results:  
I believe Alt 0173 is just a blank character

Comment 1

13 years ago
Confirmed on Win98 SE

Comment 2

13 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060121 Firefox/1.6a1 ID:2006012105 and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1 RC
This will be fixed in Firefox 1.5.0.1. You can download a RC from http://releases.mozilla.org/pub/mozilla.org/firefox/releases/1.5.0.1rc1/win32/en-US/ and verify that it does not crash. 

*** This bug has been marked as a duplicate of 319914 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.