Iframe with percentage setting for height has minimum height

RESOLVED DUPLICATE of bug 253363

Status

()

Core
Layout: HTML Frames
RESOLVED DUPLICATE of bug 253363
12 years ago
12 years ago

People

(Reporter: Daniel Hamann, Unassigned)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de; rv:1.8) Gecko/20051111 Firefox/1.5

Check the attachment. It contains the following HTML-Code:
<html><head></head><body>
<table border=1 cellpadding=0 cellspacing=0 width=100% height=100%>
<tr>
<td style="height:50%"><iframe style="height:100%" src="simple_iframe_content.html"></iframe>
</td></tr><tr>
<td align="center" valign="middle" height=50%>
Reduce the window height to see the bug!
Both table cells should always take 50% of the available space.
But there seems to be a minimum size for iframes with a <b>percentage setting for height</b>.
Gecko/20051111 Firefox/1.5
</td></tr></table></body></html>


Reproducible: Always

Steps to Reproduce:
1. Display the attachment
2 [review]. Reduce the window height
3. See how reducing the upper cell's height is stopped earlier than reducing the lower cell's height.

Actual Results:  
There seems to be a minimum height for iframes which prevents the table cell from being reduced in height

Expected Results:  
I would not expect such an iframe to have a minimum height.

This behavior makes it impossible to design page layouts with narrow iframes in table cells that are supposed to adapt their sizes to the window size.
(Reporter)

Comment 1

12 years ago
Created attachment 209337 [details]
Iframe minimum height in table cell
(Reporter)

Comment 2

12 years ago
Created attachment 209338 [details]
Iframe content file
(Reporter)

Updated

12 years ago
Attachment #209338 - Attachment is obsolete: true

Comment 3

12 years ago
Please always search for duplicates before filing new bugs.

*** This bug has been marked as a duplicate of 253363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: General → Layout: HTML Frames
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.