Closed Bug 324449 Opened 16 years ago Closed 16 years ago

error when moving a tab before it's parent and then closing it (Error: uncaught exception: 2147500037)

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 2 alpha1

People

(Reporter: Peter6, Assigned: Gavin)

References

Details

(Keywords: verified1.8.1)

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060123 Firefox/1.6a1 ID:2006012310 (in -safe-mode)

reproduce:
1. Open Firefox
2. Open 2 blank tabs
3. Open a 3rd blank tab and drag it between the first 2
4. Close that tab

result:
- You can not select any tabs
- You'll only see a gray empty window
- JS Console -> Error: uncaught exception: 2147500037
If you furthermode try to load a bookmark into the dead tabs the console shows

Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMXULElement.boxObject]
Source file: chrome://global/content/bindings/browser.xml
Confirmed: the problem is that the owner focusing code gets the owners index before closing the tab. The index to focus is then invalid after closing the tab.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #209402 - Flags: review?(bugs)
Blocks: 308396
Severity: critical → major
OS: Windows 2000 → All
Hardware: PC → All
Summary: Error: uncaught exception: 2147500037 → error when moving a tab before it's parent and then closing it (Error: uncaught exception: 2147500037)
Attached patch better patchSplinter Review
Change the comments too.
Attachment #209402 - Attachment is obsolete: true
Attachment #209402 - Flags: review?(bugs)
Attachment #209409 - Flags: review?(bugs)
Comment on attachment 209409 [details] [diff] [review]
better patch

I understand my code is a little confusing here. Inside the first for loop (//remove this tab as the owner ...) before the var tab = maybe also add a comment: 

// |tab| refers to any tab owned by the tab being removed. 

r=ben@mozilla.org
Attachment #209409 - Flags: review?(bugs) → review+
Fixed on the trunk.
mozilla/toolkit/content/widgets/tabbrowser.xml; new revision: 1.127;
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 2
fixed on the branch by bug 329054
Keywords: fixed1.8.1
Target Milestone: Firefox 2 → Firefox 2 alpha1
Verified fixed with Windows, Mac and Linux with 2.0.b1rc3 builds
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.