MLK: document.write after redirect leaks 1 document and 1 docshell

RESOLVED DUPLICATE of bug 323441

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 323441
12 years ago
12 years ago

People

(Reporter: Stuart Johnston, Unassigned)

Tracking

({memory-leak, testcase})

Trunk
memory-leak, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060125 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060125 Firefox/1.6a1

When document.write is called after a top.location.href is used to redirect the page, memory leaks occur.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Created attachment 209583 [details]
Minimal Test Case

Minimal test case attached.

Updated

12 years ago
Keywords: mlk, testcase
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060125 Firefox/1.6a1 ID:2006012505
I see this too with the testcase & leak-gauge.pl

Comment 3

12 years ago
Leak gauge reports a leak of 1 document and 1 docshell when loading the testcase. This occurs in both Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 and SeaMonkey trunk build 2006012309.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of bug 32441, not?

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 323441 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.