[mlk] Memory leak with Session Saver v0.2.1.031 extension

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
4 years ago

People

(Reporter: stevee, Unassigned)

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012609

To see this leak you must install an extension whose <maxversion> is set to 1.5
Since the trunk is 1.6a you have to do an extra few steps to get the extension installed.
Steps 4 & 5 are to force compatibility. (Alternatively, download the SessionSaver xpi and manually update the install.rdf to allow installation on 1.6a)
Nightly Tester Tools extension does not contribute to the leakage (You can uninstall it after Session Saver has been installed if you really want to)

1. New profile
2. Start Firefox
3. Tools > Options > General ; set homepage to about:blank
4. Install Nightly Tester Tools extension from https://addons.mozilla.org/extensions/moreinfo.php?id=958&application=firefox
5. Restart Firefox.
6. Install Session Saver 0.2.1.031 extension from https://addons.mozilla.org/extensions/moreinfo.php?id=436&application=firefox (Using Nightly Tester Tools to override the version clash.)
7. Restart Firefox.
8. Close Firefox

Analysis of nspr.log with leak-gauge.pl gives:

Leaked inner window 21845d8 (outer 15eb890) at address 21845d8.
 ... with URI "about:blank".
Leaked outer window 15eb890 at address 15eb890.
Leaked inner window 15e2d48 (outer 1e482e8) at address 15e2d48.
 ... with URI "chrome://browser/content/browser.xul".
Leaked outer window 1e482e8 at address 1e482e8.
Summary:
Leaked 4 out of 8 DOM Windows
Leaked 0 out of 25 documents
Leaked 0 out of 4 docshells

SessionSaver has currently been downloaded 451370 times from umo.

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060130 Firefox/1.6a1

I can confirm this, however I did not need to use Nightly Tester Tools to install Session Saver via the link to umo in Extension Manager.
(The extension confusingly claims to be version 30 in the em window).
The leak-gauge results vary in format when running subsequent tests.

See also (note the date!):
http://forums.mozillazine.org/viewtopic.php?p=2016137#2016137
I informed the developer accordingly.

Steps to reproduce:

1.Start with -profilemanager & create profile
2.Install Session Saver version 0.2.1.031 via extension manager
3.Restart Firefox
4.Quit & run leak-gauge

Comment 2

12 years ago
fixed by bug 342606?

Steve, Flummox, do you still see the problem using FF 2 or trunk?

FWIW updated version of sessionsaver @ http://wolcano.platon.sk/sessionsaver/ and more here
http://forums.mozillazine.org/viewtopic.php?t=47184&postdays=0&postorder=asc&postsperpage=15&start=2100
(Reporter)

Comment 3

12 years ago
Did you really mean bug 342606?

With Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061121 BonEcho/2.0 ID:2006112105 and a new profile, about:blank as homepage, and the SS from http://wolcano.platon.sk/sessionsaver/sessionsaver_.2-0.2.1.031-fx+mz.W-patch.xpi I still get leak-gauge.pl reporting leakage:

Leaked outer window 23461e0 at address 23461e0.
Leaked inner window 2130390 (outer 211bb70) at address 2130390.
 ... with URI "about:blank".
Leaked outer window 211bb70 at address 211bb70.
Leaked inner window 2aea358 (outer 23461e0) at address 2aea358.
 ... with URI "chrome://sessionsaver/content/little-oasis.html".
Summary:
Leaked 4 out of 9 DOM Windows
Leaked 0 out of 37 documents
Leaked 0 out of 4 docshells

Comment 4

8 years ago
stevee, possible to update the bug?  (since a lot will have changed)
no longer remember whether bug 342606 is the bug I meant.
I think this can be marked as WORKSFORME, as a lot has changed since 1.6a1.
Feel free to reopen if it's still valid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.