After Print Preview is closed, the screen gets painted black for a split second before normal content reappears

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: philip.puryear, Assigned: roc)

Tracking

({regression})

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
In today's build, after closing the Print Preview window, the page (content) area of the browser flashes black for a split second before the original content is repainted.

Repro:
1. View the Print Preview of a website (I tried mozilla.com).
2. Close Print Preview.
3. Notice that the screen goes black before the correct content is repainted.

Regression range: works on 2006-01-25-06, fails on 2006-01-26-09

Possible fallout from bug 317375?
(Reporter)

Comment 1

14 years ago
Also note that this is most likely a Core bug, although I wasn't sure which component to put it in.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout

Comment 2

14 years ago
Perhaps this should be OS:All? I see random stuff on screen after closing Print Preview (it looks like X server were using random old garbage from video memory). The window is correctly painted a split second later.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1
X Window System Version 6.8.99.903 (6.9.0 RC 3)
OS: Windows XP → All
Posted patch FixSplinter Review
We should never draw garbage. This patch adds failsafe rendering of the view manager's default background color. In the common case, the display list optimizer will prune out the background color because it will be behind the root document's background, so we won't do any extra FillRect.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #210827 - Flags: superreview?(dbaron)
Attachment #210827 - Flags: review?(dbaron)
This seems to fix bug 325407 as well.
Attachment #210827 - Flags: superreview?(dbaron)
Attachment #210827 - Flags: superreview+
Attachment #210827 - Flags: review?(dbaron)
Attachment #210827 - Flags: review+
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 6

14 years ago
I'm seeing an additional issue related to this bug. When I close the print preview, the content area no longer flashes incorrectly but vertical scrollbar area still renders garbage for a split second.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060206 Firefox/1.6a1 ID:2006020604
I'm using GTK Galaxy theme by Mandriva in case it makes the difference.
You need to log in before you can comment on or make changes to this bug.