[FIX]Major Rlk increase on balsa

VERIFIED FIXED in mozilla1.9alpha1

Status

()

defect
P1
major
VERIFIED FIXED
14 years ago
11 months ago

People

(Reporter: ispiked, Assigned: bzbarsky)

Tracking

Trunk
mozilla1.9alpha1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

During 2005-01-25 08:30 and 2005-01-25 19:20 the Rlk on balsa went from 1.80KB to around 6.33KB. CCing people who made checkins during this time.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-01-25+08%3A30&maxdate=2005-01-25+19%3A20&cvsroot=%2Fcvsroot

----------------------------------------------leaks------leaks%------bloat------bloat%
TOTAL                                          6480     250.65%   15036624      -0.94%
--NEW-LEAKS-----------------------------------leaks------leaks%-----------------------
imgContainer                                    320          -
imgContainerGIF                                 264          -
gfxImageFrame                                  1176          -
nsWeakReference                                  48          -
nsImageGTK                                     2772          -
nsProperties                                     40          -
nsVoidArray                                      16     300.00%
TOTAL                                          4636
ispiked, want to cc the people who actually checked in during the relevant interval?  I sure as heck did not check in then....

I'll try to reproduce this when I get home, but I'll need to update a tree to tip and such.
The properties stuff I did does not use nsProperties, so that's likly not it. And none of the pages that we run the leak tests on use svg, mathml or xslt which is all my other patches *should* have affected.
So... I tried debugging this and it looks to me like we're leaking some of the display list structs.  I can't tell for sure because sometime in the last week the format of the stuff that XPCOM leak logging outputs changed, so now the post-processing tools don't work right.... Compare something like:

/home/bzbarsky/mozilla/vanilla/obj-seamonkey/dist/bin/components/libgklayout.so(_ZN8nsCOMPtrI9nsIWidgetE20Assert_NoQueryNeededEv+0x3b)[0xb690282f]

to what the tools actually look for.
Assignee: nobody → roc
Component: General → Layout: View Rendering
OS: Linux → All
Product: Firefox → Core
QA Contact: general → ian
Hardware: PC → All
Most of the patch is just adding ctor/dtor logging for the structs.  The part that fixes the leaks is actually calling our destructors such that subclass destructors will get called.
Assignee: roc → bzbarsky
Status: NEW → ASSIGNED
Attachment #209938 - Flags: superreview?(roc)
Attachment #209938 - Flags: review?(roc)
Priority: -- → P1
Summary: Major Rlk increase on balsa → [FIX]Major Rlk increase on balsa
Target Milestone: --- → mozilla1.9alpha
Comment on attachment 209938 [details] [diff] [review]
Proposed patch

that's really great. Thanks so very much.
Attachment #209938 - Flags: superreview?(roc)
Attachment #209938 - Flags: superreview+
Attachment #209938 - Flags: review?(roc)
Attachment #209938 - Flags: review+
I'll land this on Sunday.
Blocks: 317375
Fix checked in.  Leaks are back down.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Not just leaks, it also seems to have brought Tp on btek back to where it was.
And I just noticed you mentioned that in bug 317375 :-)
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.