Closed Bug 324997 Opened 14 years ago Closed 10 years ago

Perform autocomplete searches even when cursor is not at the end

Categories

(Toolkit :: Autocomplete, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 497541

People

(Reporter: ajschult784, Assigned: ajschult784)

Details

Attachments

(1 file, 1 obsolete file)

As described in xpfe autocomplete bug 208871, autocomplete does not clear out search results when typing somewhere other than the end of the textbox.  It's not quite as noticable with toolkit, but if you

1. type "www.mozilla"
2. use arrow keys to go back to the left
3. type garbage
4. hit DOWN
==> you'll see the autocomplete results from step 1

The fix is to perform autocomplete searches even when not at the end.
Attached patch port SM fix (obsolete) — Splinter Review
This is a port of the SeaMonkey fix to bug 208871.  The conclusion of the discussion there was that it would be beneficial to users to show autocomplete results while they're editing the URL.
Attachment #209947 - Flags: first-review?(mconnor)
Comment on attachment 209947 [details] [diff] [review]
port SM fix

Given the API change here, let's wait until after Firefox 2 and revisit.  I'm also concerned about how this interacts with delete removing autocomplete entries.
The API change isn't actually required, it's just cleanup.  This does fix a real bug as described in comment 0.

I'm not sure what the issue might be with deleting autocomplete entries.  After deleting an entry places the cursor at the end of the text field (so the value of the parameter passed in doesn't matter).
Attachment #209947 - Attachment is obsolete: true
Attachment #213712 - Flags: first-review?(mconnor)
Attachment #209947 - Flags: first-review?(mconnor)
Attachment #213712 - Flags: first-review?(mconnor) → first-review?(bryner)
Comment on attachment 213712 [details] [diff] [review]
patch without API change

I don't think I'll be able to get to this, you might ask brettw.
Attachment #213712 - Flags: first-review?(bryner)
Attachment #213712 - Flags: first-review?(brettw)
Attachment #213712 - Flags: first-review?(brettw) → review?(brettw)
Comment on attachment 213712 [details] [diff] [review]
patch without API change

Looks OK without thinking about it too deeply.
Attachment #213712 - Flags: review?(brettw) → review+
are you wanting this for SM 2?
This seems like a duplicate of bug 497541 that already landed.  The changes in the patch in this bug seem to be incorporated into what is currently on trunk.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497541
You need to log in before you can comment on or make changes to this bug.