crash when printing this page [@ nsSubDocumentFrame::BuildDisplayList()]

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Andrew Simmons, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060129 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060129 Firefox/1.6a1

Crash when printing this page.


Reproducible: Always

Steps to Reproduce:
1. Visit URL.
2. File -> Print

Actual Results:  
Actual behaviour: Firefox crashes

Expected Results:  
Expected behaviour: Page printed


Crashed three times in a row (and when doing nothing but opening URL and printing the page) - Talkback data submitted for two of the crashes
Can you let us know the TalkbackIDs you submitted so we can have a look at the crash stack?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Can you let us know the TalkbackIDs you submitted so we can have a look at the
> crash stack?
> 

Three Talkback submissions resulting from crashes as described:
    TB14546438M
    TB14546140W
    TB14546132K

Updated

12 years ago
Keywords: crash
Summary: crash when printing this page → crash when printing this page [@ nsSubDocumentFrame::BuildDisplayList()]
(Reporter)

Comment 3

12 years ago
I get a very similar crash on another page:
http://isc.sans.org/diary.php?storyid=1078&rss

which I've certainly printed without problems in the month or so, so I'm guessing this is the same problem. (Or should I file a separate bug for the SANS.org page?)

Sounds very much like bug 324915.
Depends on: 324915
(Reporter)

Comment 5

12 years ago
hi Martijn,

(In reply to comment #4)
> Sounds very much like bug 324915.
> 

Yes, it looks rather similar, except that:

- my two sample pages that trigger the crash don't have MARQUEE tags (which the reporter of 324915 says is the common feature in his crash), 

-  the line number given in the crash dump is different (`my' crash is a segfault at nsFrameFrame.cpp, line 241; Bug 324915 is an access violation at line 203 in the same .cpp file.) Oh, and I'm on Linux rather than Win98. I don't know C++ and the codebase well enough to say whether those are significant differences, or not, tho' I'd guess so.

Comment 6

12 years ago
Incident ID: 14546438
Stack Signature	nsSubDocumentFrame::BuildDisplayList() 74cb357b
Product ID	FirefoxTrunk
Build ID	2006012904
Trigger Time	2006-01-30 01:41:35.0
Platform	LinuxIntel
Operating System	Linux 2.6.12-12mdk-i686-up-4GB
Module	firefox-bin + (001f498d)
URL visited	groups.google.com
User Comments	
Since Last Crash	0 sec
Total Uptime	3 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrameFrame.cpp, line 241
Stack Trace 	
nsSubDocumentFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrameFrame.cpp, line 241]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsTableCellFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/tables/nsTableCellFrame.cpp, line 454]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsTableFrame::DisplayGenericTablePart()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 1398]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsTableFrame::DisplayGenericTablePart()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 1398]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsTableFrame::DisplayGenericTablePart()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 1398]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsTableOuterFrame::BuildDisplayListForInnerTable()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/tables/nsTableOuterFrame.cpp, line 326]
nsTableOuterFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/tables/nsTableOuterFrame.cpp, line 298]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1432]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
DisplayLine()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6254]
nsBlockFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 6329]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsContainerFrame::BuildDisplayListForNonBlockChildren()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 225]
nsContainerFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 211]
nsPageContentFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsPageContentFrame.cpp, line 182]
nsIFrame::BuildDisplayListForChild()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1398]
nsContainerFrame::BuildDisplayListForNonBlockChildren()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 225]
nsContainerFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 211]
nsPageFrame::BuildDisplayList()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsPageFrame.cpp, line 557]
nsIFrame::BuildDisplayListForStackingContext()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsFrame.cpp, line 1123]
nsLayoutUtils::PaintFrame()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsLayoutUtils.cpp, line 622]
PresShell::Paint()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/base/nsPresShell.cpp, line 5508]
nsViewManager::Display()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/view/src/nsViewManager.cpp, line 102]
nsSimplePageSequenceFrame::PrintNextPage()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/generic/nsSimplePageSequence.cpp, line 872]
nsPrintEngine::PrintPage()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/printing/nsPrintEngine.cpp, line 3554]
nsPagePrintTimer::Notify()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/layout/printing/nsPagePrintTimer.cpp, line 92]
nsTimerImpl::Fire()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/nsTimerImpl.cpp, line 404]
handleTimerEvent()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/nsTimerImpl.cpp, line 470]
PL_HandleEvent()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/plevent.c, line 689]
PL_ProcessPendingEvents()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/plevent.c, line 623]
nsEventQueueImpl::ProcessPendingEvents()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/xpcom/threads/nsEventQueue.cpp, line 423]
event_processor_callback()  [/builds/tinderbox/Fx-Trunk/Linux_2.4.21-27.0.4.ELsmp_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 67]
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch
Andrew, does it still crash for you with the latest trunk build? It is WFM now.
(Reporter)

Comment 8

12 years ago
Confirmed that it now works for me, the page prints without problems. Changing to WORKSFORME and closing. Thanks all!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsSubDocumentFrame::BuildDisplayList()]
You need to log in before you can comment on or make changes to this bug.