Closed Bug 325241 Opened 15 years ago Closed 8 years ago

Make it possible to query and observe hidden items

Categories

(Toolkit :: Places, defect, P4)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: brettw, Unassigned)

References

Details

The query options has the ability to give hidden items as well as the normal items. This lets you see images and iframe contents, for example.

We need to make sure this works. This will depend on getting hidden item notifications working. It also may require a small change to the patch in bug 317843 to send redirect information even when items are not toplevel pages.
Priority: -- → P4
Hidden item notifications aren't currently complete. I think querying works now, but the results won't stay up-to-date.
Summary: Make sure querying hidden items work → Make it possible to query and observe hidden items
*** Bug 319216 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Firefox 2 alpha2
Whiteboard: swag: 2d
Target Milestone: Firefox 2 alpha2 → Firefox 3
Assignee: brettw → nobody
Whiteboard: swag: 2d
Target Milestone: Firefox 3 → ---
Product: Firefox → Toolkit
QA Contact: places → places
Depends on: 766799
this bug is pointless, we'll fix bugs when we actually hit it.
Also the situation about hidden is quite improved atm, we instead plan to make them LESS visible.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.