Closed Bug 32536 Opened 20 years ago Closed 19 years ago

text gets wrong font size

Categories

(Core :: Layout, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED
mozilla1.0

People

(Reporter: juberti, Assigned: pierre)

References

()

Details

(Keywords: testcase)

Attachments

(4 files)

When diffing using Bonsai at AOL or at mozilla.org I get extra linefeeds. I
don't see this with IE5 or NS 4.7. See
http://cmihoss.office.aol.com:2000/client/bonsai/cvsview2.cgi?command=DIFF&subdir=cool%2FInclude&file=CoolVersion.h&rev1=1.15&rev2=1.16&whitespace_mode=show&diff_mode=context
for an example.

I saw this in the 3-16-b1 windows build.
sounds like a layout issue; not an editor issue
Assignee: brade → troy
Component: Editor → Layout
QA Contact: sujay → petersen
Line layout issue
Assignee: troy → buster
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
could you please attach a test case that is publically accessable?  you could
either save the html to disk then upload it using the bugzilla form, or point to
a bonsai page off of mozilla.org that shows the problem.  Thanks!
Status: NEW → ASSIGNED
Attached file Example of problem
Seems the LF problem is fixed, but now the type size is too big compared to 
4.7, so the diffs don't fit in the browser window.
looks like this might be a style resolution or font mapping problem.  assigning
to marc so he can validate we're getting the right style, cc-ing erik in case
it's font mapping.
Assignee: buster → attinasi
Status: ASSIGNED → NEW
Summary: Extra linebreaks when viewing Bonsai diffs → text gets wrong font size
We are getting the correct font sizes in the Style Context, as show by dumping
the style context data from Viewer.

Additionally, the font size for the Lucida Console font, sized at -1 looks to me
to be the same as that of Nav4. In fact, I've created a testcase with that face
in sizes from -5..5 and they look pretty much the same as Nav4.

Is this really a bug? When I laod the attachment in NS6 (buildID 200092808) and
Nav4 and compare them, each visible line is showing up to the same character...

Closing as WORKSFORME - if I am missing something here, please re-open and
explain how the font size is wrong (a picture would be great too). Thanks.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Reopening: Buster just showed me how his machine shows the page, and the
testcase I attached, and I see that it different. On my machine, using a NS6
build from yesterday, the font sizes look the same. Using a tip-of-branch build
from today, the font sizes *are* different...

Over to Erik: did something change in font sizing in the last day? size=0 and
size=-1 look different sizes, and size=4 has different weight. I'll attach
screen shots to show the differences.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Sending to Erik - the font size mappings seem to have changed (in the last day
even). Can you make it out?

(Also, I updated the URL to the public page)
Assignee: attinasi → erik
Status: REOPENED → NEW
I don't know of any recent changes in the <font size=-1> code. Pierre, do you
know of any? Could it be related to some changes in the strict vs compat mode?
If I recall correctly, the font sizing depends on that mode.
Assignee: erik → pierre
I can't explain why N6 and Moz differ, but there is a logical explication about 
why <font size-0> isn't the same as Nav4 (default prefs, I think).

Marc: Size 4 doesn't have a different weight. The Moz sizes (except for 0) are 
all one step smaller than the N6 sizes.
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
Moving to m1.0
Target Milestone: --- → mozilla1.0
Is this still a useful report? If it is can someone please remove the Netscape
Confidential flag or if there is real proprietary info I'll be glad to file a
clean version so we can resolve this Netscape Confidential bug as invalid. 
Removing Netscape confidential. The problem is demonstrated by the attachments 
and so the original AOL internal URL is not needed. Also, I am no longer seeing 
the extra linefeeds in Moz 0.8, but the different text size issue remains.
Group: netscapeconfidential?
Looks like this a dup with bug 72164 -- the font-size mapping code in
nsStyleUtil.cpp needs to be revisited.
Depends on: 72164
Blocks: 79928
No longer blocks: 79928
Should be fixed as part of my font changes in bug 99010.
pierre, you might to check if things are okay with you.
Marking as FIXED now.
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → FIXED
Marking verified in the Oct 22nd build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.