No indication of current field when tabbing into radio button groups

VERIFIED DUPLICATE of bug 1859

Status

()

Core
Layout: Form Controls
P2
normal
VERIFIED DUPLICATE of bug 1859
19 years ago
18 years ago

People

(Reporter: paul, Assigned: Eric Pollmann)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
1. Have NGLayout display a form containing radio buttons and checkboxes.

2. Tab into these fields.  You'll notice that there's no visual clue as to which
control currently has the input focus.

This is the behavior using a Win32 optimized build of NGLayout, running under NT
4.0.

Updated

19 years ago
Assignee: karnaze → joki

Comment 1

19 years ago
Tom: when the tab manager is working, please reassign this bug to me.

Updated

19 years ago
Assignee: joki → karnaze

Comment 2

19 years ago
Oh sorry, you do have a bug for this.

Updated

19 years ago
Assignee: karnaze → pollmann

Updated

19 years ago
QA Contact: 4110 → 4137

Comment 3

19 years ago
Reassigning QA contact to cpratt@netscape.com (FORM QA contact).
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M6
(Assignee)

Comment 4

19 years ago
Redistributing to M8...
(Assignee)

Comment 5

19 years ago
Didn't make M8
(Assignee)

Updated

19 years ago
Component: Form Submission → HTML Form Controls
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M11 → M13
(Assignee)

Comment 6

19 years ago
Tabbing doesn't work for GFX widgets.  That needs to be fixed first.
(Assignee)

Comment 7

19 years ago
Well, it does sortof, I lied.  See this test case:

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=694

Comment 8

18 years ago
QA Contact update.
(Assignee)

Updated

18 years ago
Summary: No indication of current field when tabbing into checkbox or radio button groups → No indication of current field when tabbing into radio button groups
(Assignee)

Comment 9

18 years ago
This is true for radio buttons but no longer true for checkboxes.  Cool!

It probably "only" requires a change to html.css I'll try it out and see.  If
we're so lucky, I'll try to get this in to M13!
Target Milestone: M13 → M16
Moving to M16. Cosmetic problem but still usable in interim.
(Assignee)

Comment 11

18 years ago
Lowering priority, as this is not critical in relation to some of my other bugs.

 1) major regressions
 2) development blockers
 3) crashers and major usability issues
 4) cosmetic issues and standards compliance issues

This falls in category 4 and relatively minor.  Moving off to M19.

(Assignee)

Comment 12

18 years ago
CC'ing folks who might be interested in focus issues / gfx form controls.
Target Milestone: M16 → M19
Less-than-ideal UE but you can still operate the form. Move to FUTURE if run out 
of time.
(Assignee)

Comment 14

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M19 → Future

Comment 15

18 years ago
I hope this will be solved in the not to far furture, since this can be very a
annoying if there are a lot of radio buttons on the page.
Since this could be solved for the checkboxes, it shouldn't be to difficult.
this week i hope

*** This bug has been marked as a duplicate of 1859 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 17

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 18

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.