Last Comment Bug 325410 - Mac builds not packaging .chk files
: Mac builds not packaging .chk files
Status: RESOLVED FIXED
[camino-1.0]
: fixed1.8.0.2, fixed1.8.1
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- critical (vote)
: ---
Assigned To: Mark Mentovai
:
Mentors:
Depends on:
Blocks: 327848
  Show dependency treegraph
 
Reported: 2006-01-31 21:47 PST by Mark Mentovai
Modified: 2006-02-21 19:39 PST (History)
5 users (show)
dveditz: blocking1.8.0.2+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix paths to shlibsign for Mac builds (3.53 KB, patch)
2006-01-31 21:48 PST, Mark Mentovai
no flags Details | Diff | Splinter Review
Fix paths to shlibsign for Mac builds (3.67 KB, patch)
2006-01-31 22:02 PST, Mark Mentovai
benjamin: review+
wtc: review+
wtc: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
Fix paths, 1_8_0 branch version (2.79 KB, patch)
2006-02-20 17:32 PST, Mark Mentovai
wtc: review+
dveditz: approval1.8.0.2+
Details | Diff | Splinter Review

Description Mark Mentovai 2006-01-31 21:47:33 PST
The packager is not producing .chk files for Mac builds, because it's not finding the NSS libraries.  This should be fixed immediately on the trunk and all branches.
Comment 1 Mark Mentovai 2006-01-31 21:48:37 PST
Created attachment 210322 [details] [diff] [review]
Fix paths to shlibsign for Mac builds
Comment 2 Mark Mentovai 2006-01-31 21:51:10 PST
Comment on attachment 210322 [details] [diff] [review]
Fix paths to shlibsign for Mac builds

(The NO_PKG_FILES ifdefs are because I override that variable, setting it to empty, during Camino packaging.)
Comment 3 Mark Mentovai 2006-01-31 22:02:45 PST
Created attachment 210324 [details] [diff] [review]
Fix paths to shlibsign for Mac builds

Realized that _BINPATH allows the removals stuff to be collapsed too.
Comment 4 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-02-02 07:05:39 PST
Comment on attachment 210324 [details] [diff] [review]
Fix paths to shlibsign for Mac builds

>Index: mozilla/toolkit/mozapps/installer/packager.mk

>+ifdef NO_PKG_FILES
>+	cd $(DIST)/$(MOZ_PKG_APPNAME)$(_BINPATH); rm -rf $(NO_PKG_FILES)
>+endif

Why the ifdef? We set NO_PKG_FILES in this makefile, so it's never going to be empty...
Comment 5 Mark Mentovai 2006-02-02 07:18:52 PST
See comment 2
Comment 6 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-02-02 07:20:18 PST
oh... why do you do that? Be very careful because you could end up accidentally shipping LGPL code (xpidl).
Comment 7 Mark Mentovai 2006-02-02 08:09:57 PST
Camino.app is produced entirely in Xcode from a clean slate by hand-picking the files that we do want to package.  We don't bring everything in from $(DIST)/bin.

The reason I override it, from camino/installer/Makefile.in:

# packager.mk has its own exclude list that's appropriate for toolkit apps
# but not appropriate for the Xcode-built Camino.  Specifically, it excludes
# the files produced by Camino.app/Contents/MacOS/Camino -autoRegister YES,
# although they belong in the package.  Override.
NO_PKG_FILES=

The Camino build script registers components after the build and before packaging.
Comment 8 Mark Mentovai 2006-02-02 19:28:00 PST
Checked in on the trunk and Camino 1.0 branch.  Nominating for other branches because .chk files are required for FIPS mode.  http://www.mozilla.org/projects/security/pki/nss/tech-notes/tn6.html
Comment 9 Wan-Teh Chang 2006-02-20 16:43:41 PST
Comment on attachment 210324 [details] [diff] [review]
Fix paths to shlibsign for Mac builds

Mark, could you check this patch in on the MOZILLA_1_8_BRANCH?

This patch would need to be adjusted for the
MOZILLA_1_8_0_BRANCH because the names of the
NSS files that need to be signed are different
on that branch.
Comment 10 Mark Mentovai 2006-02-20 17:29:23 PST
Checked in to MOZILLA_1_8_BRANCH.
Comment 11 Mark Mentovai 2006-02-20 17:32:15 PST
Created attachment 212543 [details] [diff] [review]
Fix paths, 1_8_0 branch version

This is the same patch as above, adjusted for the 1_8_0 branch.

This patch is highly recommended: it generates and packages .chk files, a requirement for NSS to operate in FIPS mode.
Comment 12 Daniel Veditz [:dveditz] 2006-02-21 15:28:09 PST
Comment on attachment 212543 [details] [diff] [review]
Fix paths, 1_8_0 branch version

approved for 180 branch, a=dveditz for drivers
Comment 13 Mark Mentovai 2006-02-21 19:39:39 PST
Fixed on 1_8_0.

Note You need to log in before you can comment on or make changes to this bug.