Closed Bug 325427 Opened 14 years ago Closed 4 years ago

SVG <use> hang with reference loops

Categories

(Core :: SVG, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Assigned: jwatt)

References

(Blocks 1 open bug)

Details

(Keywords: hang, perf)

Attachments

(4 files)

 
I'm finding it difficult to reduce this further by guessing, because many changes cause it to hang for 10 seconds instead of hanging indefinitely.
I noticed that memory usage increases by about 1MB per second until I kill Firefox using Task Manager.

Btw, I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060131 Firefox/1.6a1.
I also experience various hanging conditions. Does anyone have an idea of what are the causes behind this behaviour? Even if a fix is not provided, knowing what sort of SVG documents to avoid would be useful.
WFM (Intel Mac, trunk, debug).  But I originally reported this on Windows, so I'm not marking it as WFM.
Still present in current trunk builds on Windows.
Assignee: general → nobody
QA Contact: ian → general
This just takes out the extraneous <g> tags. The testcase still hangs for quite a long time for me on mac - 23 seconds - but not as long as the original.
Simply removing the attributes from the <line>, <rect> and <text> tags further reduces the hang time to about 16 seconds.
Assignee: nobody → jwatt
Keywords: perf
Blocks: 592129
OS: Windows XP → All
Hardware: x86 → All
Summary: SVG hang, possibly due to reference loop → SVG <use> hang with reference loops
Testcase works without issue now.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Depends on: 1219868
You need to log in before you can comment on or make changes to this bug.