Flash is not rendered properly with Cairo builds

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: atzaus, Assigned: vlad)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cairo, URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 (bangbang023)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 (bangbang023)

On almost all websites (cnet.com, miniclip.com etc) flash is not rendered properly .

Reproducible: Always

Steps to Reproduce:
1. Download a Cairo build
2. Visit www.cnet.com
3. Look at the top flash object

Actual Results:  
The flash object isn't displayed properly

Expected Results:  
The flash object should render like the non-cairo builds

Using Macromedia Shockwave Flash 8.0 r22
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060123 Firefox/1.6a1 ID:2006012317
cairo build

Confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: cairo

Comment 2

12 years ago
As far as I can see, it is not rendered properly due to scrolling issues.
I can't reproduce this with today's build.  Could have been fixed by bug 328263.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060224 Firefox/1.6a1 ID:2006022408

WFM

*** This bug has been marked as a duplicate of 328263 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
The flash on this page still does not display correctly.  There are several flash elelments. One of them appears to now display with the checkinn for 328263, but that does not make the whole page work.  For another example, try http://www.comcast.net/home.html
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

12 years ago
On the following page two flash objects aren't displayed:
http://www.bloodlinesmovie.com/

Tested on Trunk Build 2006022410 on WinXP SP2, patched.

Dex

Comment 8

12 years ago
http://www.bloodlinesmovie.com/

I stumbled over a detail. After installing the User Agent Switcher extension and switching to Netscape 4.8 (Windows XP), Opera 8.51 (Windows XP) or Internet Explorer (Windows XP) the SWFs are displayed, just without transperancies. Switching to the default UA or a Firefox 1.5 one the SWFs aren't displayed at all. On a non-Cairo Firefox 1.5.0.1 everything is working properly.

Maybe the problem is related to the transperancies of the SWFs?

Tested on Trunk Build 2006030205 on WinXP SP2, patched.

Dex 

(In reply to comment #8)
> http://www.bloodlinesmovie.com/
> 
> I stumbled over a detail. After installing the User Agent Switcher extension
> and switching to Netscape 4.8 (Windows XP), Opera 8.51 (Windows XP) or Internet
> Explorer (Windows XP) the SWFs are displayed, just without transperancies.
> Switching to the default UA or a Firefox 1.5 one the SWFs aren't displayed at
> all. On a non-Cairo Firefox 1.5.0.1 everything is working properly.
> 
> Maybe the problem is related to the transperancies of the SWFs?
> 
> Tested on Trunk Build 2006030205 on WinXP SP2, patched.
> 
> Dex 
> 
I can confirm this.  All of the sites which I have flash issues with work perfectly if I change the User-agent string to idnetify the broswer to be anything other than Firefox.

Updated

12 years ago
Blocks: 329766
Blocks: 331759
Flags: blocking1.9a1?

Comment 10

12 years ago
(In reply to comment #9)
 
> > I stumbled over a detail. After installing the User Agent Switcher extension
> > and switching to Netscape 4.8 (Windows XP), Opera 8.51 (Windows XP) or Internet
> > Explorer (Windows XP) the SWFs are displayed, just without transperancies.
> > Switching to the default UA or a Firefox 1.5 one the SWFs aren't displayed at
> > all. On a non-Cairo Firefox 1.5.0.1 everything is working properly.
> > 
> > Maybe the problem is related to the transperancies of the SWFs?
> > 
> > Tested on Trunk Build 2006030205 on WinXP SP2, patched.
> > 
> > Dex 
> > 
I can confirm this, too. Thanx for the workaround.

cheers
mbb
Blocks: 334728

Comment 11

12 years ago
Given that the problem goes away with a user-agent switch, this sounds like a Flash Player bug, yes? Or will the Cairo user-agent string be changing to the regular Firefox one in the future?

Where can a Cairo build be downloaded from?

Is this a Win only issue or also Mac and Linux?
That's probably because at that point they switch into windowed mode instead of windowless, which is more compatible and should work just about anywhere.  In windowed mode the plugin has to play nice with the rest of the rendering (or rather, the browser has to set up things in a way that the plugin expects; we're clearly not doing that now).

Updated

12 years ago
Blocks: 338467

Comment 13

12 years ago
from bug 338467:
another problem is http://tdc.gemal.dk/flashhub.html where the flash is shown at the wrong place.

Comment 14

12 years ago
Could this bug be related to this behaviour?

On http://efectokiwano.net/mm/ (this is just an example - it happens anywhere) there is a mindmapping application.
For quite a while back, the text is not displayed in flash objects.

It certainly does not work on Linux builds.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a2) Gecko/20060518 BonEcho/2.0a2 - Build ID: 2006051804
Shockwave Flash 7.0 r63

Comment 15

12 years ago
Created attachment 222597 [details]
Flash fonts display problem

Here is what I mean

Comment 16

12 years ago
Nevermind that!

Found the explanation: 
http://macromedia.mplug.org/faq.html#font

Sorry!
The header of the main (blue) article here is gone:
http://www.nieuwnieuws.nl/
I see it only when the site is loading, when the site has finished loading the header disappears.
So the flash is rendered well, but disappears finally for unknown reasons.
I see the same thing as the above comment; using the 1 June trunk build on Windows.
*** Bug 329766 has been marked as a duplicate of this bug. ***
*** Bug 324496 has been marked as a duplicate of this bug. ***
Created attachment 224492 [details] [diff] [review]
fix windowless plugins

The origin wasn't being set correctly (it was pulling it out of GetTranslationCoord, which was returning the offset with a twips scale applied [perhaps incorrectly, but it was inefficient anyway]); also, the win32 ViewportOrgEx origin was being calculated incorrectly (- instead of +).  All the various flash test cases work fine for me (in this and the dup'd bugs) with this patch.
Assignee: nobody → vladimir
Status: REOPENED → ASSIGNED
Attachment #224492 - Flags: review?(pavlov)

Updated

12 years ago
Attachment #224492 - Flags: review?(pavlov) → review+
Checked in, yay.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
*** Bug 331759 has been marked as a duplicate of this bug. ***
Flags: blocking1.9a1?
You need to log in before you can comment on or make changes to this bug.