Replace "Products" section with "Projects" section on www.mozilla.org

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: pkim, Assigned: davidwboswell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
As Mozilla product content now lives on mozilla.com, we should look at modifying the "Products" section on mozilla.org to focus on ongoing Mozilla projects.

Initial thoughts on the scope of work:

1. Assess amount of site content currently living at mozilla.org/products/ to determine level of redirects, etc. that would be caused by this change.

2. Replace the navigation tab across www.mozilla.org for Products with a tab for Projects. 

3. Create a new main page for Mozilla Projects that splits out the various .org projects into three categories: applications, technologies, and activities, and lists the contents of the current mozilla.org/projects and mozilla.org/products pages, as well as community activity pages like spreadfirefox.com.

4. Provide links to mozilla.com/products for people interested in Firefox and Thunderbird.
--> websites/*.mozilla.org
Component: www.mozilla.org → *.mozilla.org
Product: mozilla.org → Websites
Version: other → unspecified
Bugs relating to content with www.mozilla.org go in mozilla.org :: www.mozilla.org. This component will eventually be moved to the Websites product, but not until justdave finishes some type of script to move the component (afaik).

--> mozilla.org :: www.mozilla.org
Component: *.mozilla.org → www.mozilla.org
Product: Websites → mozilla.org
Version: unspecified → other

Updated

13 years ago
Depends on: 341804

Comment 3

13 years ago
Who is resonsible for mozilla.org content right now?
Is there agreement that this is the right way to go?
Who would take over this effort?
Should it be split into several smaller bugs/tasks?

Bug 341804, which I just filed, should be a small step in this direction which is not covered yet in the comments in this bug.
First of all, sorry for the long article that is to follow ;-)


I took the liberty to classify the current entries on www.mozilla.org/projects into different categories. The different categories are:

- Active projects with a high visibility
  These projects should be listed at the top of the page with a more prominent 
  entry and their logo (if they have one).

- Active Projects wit a lower visibility
  These projects would still be listed, but after the more prominent projects.

- Projects which have been abandoned (or completed)
  The entries for these projects should be deleted from the page (probably 
  their corresponding web content should also be deleted).

- Entries that should be deleted, because they are on mozilla.com
  This entry comprises the content that can currently be found on the project 
  pages for Firefox and Thunderbird. These entries should be removed from the 
  website, because these are not mozilla.org projects.

- Entries that should be deleted because of other reasons
  I don't think we need this stuff any longer.

- Projects where I'm unsure of their current status
  There are a lot of projects, where I do not know if they are still active or 
  have been abandoned. We should try to find out what their current status is 
  and move them to the "active with lower visibility" or "abandoned" category. 

  There are some cases, where I know that the projects are active (e.g. Gecko) 
  but the web content is pretty outdated and we should decide, whether these 
  projects should still be listed on the projects page. It serves nobody, if 
  people visit an outdated web page from 2003, even if the code is still 
  actively developed.


And here's the full list with my categorization. If this finds your approval, I 
would volunteer to reorganize and streamline the projects page.

Active projects with a high visibility:
=======================================
- Bugzilla
- Calendar (Sunbird & Lightning)
- Camino
- Chatzilla (Chat & Instant Messaging)
- Minimo
- Seamonkey

Active Projects wit a lower visibility:
=======================================
- Accessibility
- CCK
- Directory (LDAP)
- DOM Inspector
- Grendel
- Help Viewer
- JavaScript
- Localization (L10N)
- Marketing Project
- Mozilla Documentation Project
- Netscape Portable Runtime (NSPR)
- Network Security Services (NSS)
- Network Security Services for Java (JSS)
- Penelope
- Plug-ins
- Ports
- Rhino
- Scalable Vector Graphics (SVG)
- Tamarin
- Venkman (JS Debugging)
- XForms

Projects which have been abandoned (or completed):
==================================================
- BiDi
- ColorSync
- Editor 
  There is a Composer project headed by glazman, but that is 
  developed outside of mozilla.org)
- Platform for Privacy Preferences (P3P)
- Search
- SilentDownload
- Unix
- User Interface
- XPNet
- Xprint

Entries that should be deleted, because they are on mozilla.com:
================================================================

- Mozilla Firefox
- Mozilla Thunderbird

Entries that should be deleted because of other reasons:
========================================================
- Browser Distributions
- Other

Projects where I'm unsure of their current status:
==================================================
Many of these projects might be still active but in many cases 
the web content on the project pages is heavily outdated

- Blackwood
- Bonsai
- Component Security
- Embedding
- Footprint
- Internationalization (I18N)
- Mail/News
- MathML
- Mozbot
- Netlib (Necko)
- New Layout (Gecko)
- Open JVM Integration
- Performance
- Personal Security Manager (PSM)
- PKCS #11 Conformance Testing
- PyXPCOM
- RDF
- SQL Support
- Technology Evangelism
- Tinderbox
- Web Services
- XBL
- XML Extras
- XML-RPC
- XPCOM
- XPConnect
- XPInstall
- XPToolkit (XPFE)
- XSL Transformations (XSLT)
- XUL

Comment 5

12 years ago
Restructuring the projects page is out of the scope of this bug, and should be taken to the newsgroups, as Bugzilla is no discussion forum.
I don't think any project can be deleted from such a list completely, but that's all up the website maintainers and Mozilla Foundation, and again should be discussed on the newsgroups.
After a recent mail exchange with Reed, he told me that this is the bug where such (as I propose it) should be discussed. In addition as I read the bug description, item 3 from pkim's list seems to match my proposal pretty good.

Comment 7

12 years ago
OK, it's probably the right bug, but I feel we need some discussion for get the details done correctly, but I refuse to do lengthy discussion in bug reports as they're just not discussion forums. I'd have some comments about your proposal, but I'll only make them in a newsgroup thread, as Bugzilla doesn't work well for real discussions.
I posted my thoughts in the mozilla.dev.mozilla-org newsgroup. See 
http://groups.google.de/group/mozilla.dev.mozilla-org/browse_frm/thread/6f57629383cab883/644d58ed5f93e309#644d58ed5f93e309

Please reply to my post with your thoughts on this matter.
(Assignee)

Comment 9

12 years ago
Now that the Projects page on www.mozilla.org has been updated, let's take another look at this bug.  To address pkim's original points:

> 3. Create a new main page for Mozilla Projects that splits out the various 
> .org projects into three categories: applications, technologies, and 
> activities, and lists the contents of the current mozilla.org/projects and 
> mozilla.org/products pages, as well as community activity pages like 
> spreadfirefox.com.

Done.  See Bug 393447 for details.  Note that the new Projects page doesn't include an Activities section though.  IMO, this is something we could put on an updated Community page.

> 4. Provide links to mozilla.com/products for people interested in Firefox and
> Thunderbird.

The new Projects page links directly to both the Firefox and Thunderbird pages on mozilla.com so I'm not sure if also linking to mozilla.com/products is needed.

> 1. Assess amount of site content currently living at mozilla.org/products/ to
> determine level of redirects, etc. that would be caused by this change.

It looks like we should redirect the following pages to www.mozilla.org/projects:

http://www.mozilla.org/products/
http://www.mozilla.org/products/choosing-products.html
http://www.mozilla.org/download.html

> 2. Replace the navigation tab across www.mozilla.org for Products with a tab
> for Projects. 

We just need to make a simple change to the few template pages to switch Products to Projects.  I can attach a patch for these changes in a bit.

Comment 10

12 years ago
If we kill download.html, we should also kill those entries in VARIABLES that are only used on that page - that is, if we don't want to keep such a common overview download page.
(Assignee)

Comment 11

12 years ago
Assignee: nobody → david
Status: NEW → ASSIGNED
Attachment #299813 - Flags: review?(reed)
Comment on attachment 299813 [details] [diff] [review]
Patch for switching Products to Projects in top-level nav

So, what do you think about renaming template-products.html to template-projects.html? I think it's going to be really confusing to still use "products" on pages so that the correct template is used when we really want to use "projects". This will require some work to get right, but I think it's worth it. What do you think?
(Assignee)

Comment 13

12 years ago
Renaming template-products.html to template-projects.html is fine with me if it will help avoid confusion in the future.  That's a bit out of scope for what I'm able to do though, so I'd be happy to work with someone to make this change.
(Assignee)

Comment 14

12 years ago
Note that I just made a new redirect for download.html and didn't change the existing download/ redirect.  I don't have the history here so I'm not sure if both of those should be changed or not.
Attachment #299815 - Flags: review?(reed)
Comment on attachment 299813 [details] [diff] [review]
Patch for switching Products to Projects in top-level nav

Ok, I'll work on renaming it later. Will probably get a cvs copy done since I want to keep the history. This is good enough for a start, though.
Attachment #299813 - Flags: review?(reed) → review+
Comment on attachment 299815 [details] [diff] [review]
Patch for redirects for Products to Projects switch

>+Redirect permanent /products/index.html http://www.mozilla.org/projects/

I'm curious if this will match for /products/, but we'll see...
Attachment #299815 - Flags: review?(reed) → review+
(Assignee)

Comment 17

11 years ago
The Products link in the nav has been switched over to Projects (see bug 433036 for details) but we still need to set up redirects for the Products pages and handle other items mentioned in this bug -- renaming the products template, remove the entries in the VARIABLES file, etc.
Product: mozilla.org → Websites
(Assignee)

Comment 18

10 years ago
Closing as fixed.

A new bug was recently opened to deal with the VARIABLES file -- bug 477085.

If there are any other files to clean up as part of replacing the Products section with the Projects section, please open a new bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.