The default bug view has changed. See this FAQ.

ChatZilla should be closing its <script> tag in outputwindow.html

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
critical
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Gijs, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.71])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Testcase coming up. This breaks ChatZilla.

Updated

11 years ago
Blocks: 305873
No longer depends on: 305873
(Reporter)

Updated

11 years ago
Assignee: mrbkap → rginda
No longer blocks: 305873
Status: UNCONFIRMED → NEW
Component: HTML: Parser → ChatZilla
Ever confirmed: true
Keywords: regression
Product: Core → Other Applications
QA Contact: parser → samuel
Summary: HTML parser puts everything after <script /> in a script node (in an XHTML doctyped doc) → ChatZilla should be closing its <script> tag in outputwindow.html

Comment 1

11 years ago
Created attachment 210411 [details] [diff] [review]
add </script>

Add back the </script> tag. Whether we want to keep the output window as html or change to xml is for later discussion.
Attachment #210411 - Flags: review?(samuel)

Updated

11 years ago
Attachment #210411 - Flags: review?(samuel) → review+
(Reporter)

Comment 2

11 years ago
Checked in, so hopefully FIXED. (assuming that for once today, I've gotten something right...)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 3

11 years ago
FWIW, I disagree with the fix of bug 305873, but I bet no-one gives a fuck.
Depends on: 305873
Well, if you state your case in a sensible manner in that bug i'm sure people will listen.
Blocks: 305873
No longer depends on: 305873
(Reporter)

Comment 5

11 years ago
*** Bug 326032 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
*** Bug 327225 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Whiteboard: [cz-0.9.71]
You need to log in before you can comment on or make changes to this bug.