bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Browser crashes when visiting URL

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Pavel, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Browser crashes when opening URL http://www.icellcom.co.il/icons



Reproducible: Always

Steps to Reproduce:
1. Open http://www.icellcom.co.il/icons
2.
3.

Actual Results:  
Browser crashes

Expected Results:  
Open requested URL

Talkbacks: TB14700140Y, TB14699993K
TB TB14699993K

Stack Signature	 0x0209a60b eaede410
Product ID	Firefox15
Build ID	2006011112
Trigger Time	2006-02-03 05:18:36.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	
User Comments	
Since Last Crash	3490 sec
Total Uptime	3490 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x0209a60b
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
XPC_WN_Shared_Proto_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1543]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
XPC_WN_Shared_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 710]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
XPC_WN_Shared_Proto_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1543]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1233]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
XPC_WN_Helper_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1030]
js_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 4234]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
nsNodeSH::Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/dom/src/base/nsDOMClassInfo.cpp, line 6236]
XPC_WN_Helper_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1030]
js_Mark  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 4234]
MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1146]
js_MarkGCThing  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1446]
js_GC  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1702]
js_ForceGC  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsgc.c, line 1510]
nsAppStartup::Run  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x2141a (0x77e8141a)
Version: unspecified → 1.5 Branch
Also no crash with my Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1 ID:2006011112 at this site.

Reporter: Do you use any extension ? 

Please try to start Firefox in Safemode (http://kb.mozillazine.org/Safe_mode) and test if your Firefox also crashs.

Updated

13 years ago
Component: General → Build Config
Product: Firefox → Core
Version: 1.5.0.x Branch → 1.0 Branch

Comment 5

13 years ago
have things already gone bad by the time garbage collection happens?
Component: Build Config → JavaScript Engine

Comment 6

13 years ago
Talkbackid from todays crash:
UnmarkedGCThingFlags 4d18c9ae
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=15756311

See reproduction steps listed in bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=328787
comment#7
Assignee: nobody → general
QA Contact: general → general

Comment 7

12 years ago
I can't reproduce a crash in ff 1.5.0.5/winxp. marking works for me. Please reopen if you can reproduce with a recent 1.5.0.4 or 1.5.0.5 build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.