Closed Bug 325975 Opened 15 years ago Closed 15 years ago

Unwanted "Find" Toolbar

Categories

(Toolkit :: Find Toolbar, defect)

1.8.0 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 311376

People

(Reporter: JShughart, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Find toolbar pops up when pressing forward slash or apostrophe whenever typing in text boxes. Appears only for brief moment, but prevents user from using that character.

Reproducible: Always

Steps to Reproduce:
1. Open up your favorite blog
2. Try to post a new entry
3. Try to use forward slash or apostrophe

Actual Results:  
Find toolbar pops up unwanted.

Expected Results:  
It should have just posted the character pressed, without accessing the find toolbar
Could be related to bug 287179.
What keyboard layout you are using?
(In reply to comment #2)
> What keyboard layout you are using?
> 

Standard US Keyboard layout. 102 keys, if I recall correctly.
Not a bug, but a feature. It is find as you type feature.

Go to edit / preferences / Advanced and uncheck "Begin finding..."

-> INVALID ?
(In reply to comment #4)
> Not a bug, but a feature. It is find as you type feature.
> 
> Go to edit / preferences / Advanced and uncheck "Begin finding..."
> 
> -> INVALID ?
> 

I did uncheck that....still does it anyways.
Unless you press it together with Alt+Ctrl it should not be related to bug 287179. 
What blogging software and version are you using (Blogger, Movable Type, WordPress, etc)?  Are you using a wysiwyg editing mode or a plaintext editing mode?  Does this happen all the time or only sometimes?
Blocks: findgrabs
Happens sometimes. Enough though that it's extremely annoying. It happens with all text boxes...wysiwyg or not.
I have found a temporary workaround for this bug (which seems to be NOT fixed).  If you go to about:config and look for the "accessibility.typeaheadfind.flashBar" Preference Name and change its value from 0 or 1 (if it is 0, change it to 1; if it is 1, change it to 0) then the feature seems to "reset" and you will be able to enter in the arbitrary characters in textboxes again.
I also have this behaviour.
The only thing I have discovered is when the toolbar was inserted, a special "links-only" mode was incorporated which displays the searchbar when / or ' are pressed.
Somehow this mode is being triggered even when there are input fields on the screen.
I believe this is a recent (1.5.0.3) modification because I have been reproducing it quite often under different circumstances for the last couple of days.
Confirming on 1.5.0.3 on WinXP Pro.

User was repeating something they do almost daily.  Other days it worked and works fine.  Today ...

  1)  Goto login page 

  2)  Type username in username text field

  3)  Begin typing password in password text field.

  4)  Password contains a forward slash "/".  When type the "/", Firefox
      enters FAYT mode and begins searching page.

There was no way to enter the password.  I believe the user rebooted and it worked (I don't know if he tried exiting and restarting Firefox).

The webpage is a standard Citrix Web Interface login page; the user uses it daily, and millions use similar pages.  I'll attach the page source.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is really a frame in the page, but I think that's irrelevant.  All the content is in this frame; the full page adds only a hidden frame that implements a timeout feature.
severity: normal -> minor
version: unspecified -> 1.5.0.x branch
component: General -> Find Toolbar / FastFind
Severity: normal → minor
Component: General → Find Toolbar / FastFind
Version: unspecified → 1.5.0.x Branch

*** This bug has been marked as a duplicate of 311376 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.