Disappearing selected text in inputs when they're very full

RESOLVED DUPLICATE of bug 302294

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 302294
13 years ago
10 years ago

People

(Reporter: zerrez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050819 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050819 Firefox/1.0.6

app-5 > /usr/lib/mozilla-firefox/mozilla-xremote-client: Error: Failed to find a
 running server.
No running windows found
*** loading the extensions datasource
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 342732 error_code 2 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
firefox-bin exited with non-zero status (1)

[1]    Exit 1  

Reproducible: Always

Steps to Reproduce:
1. copy a lot of **** into the search field (CTRL+F or search bar)
2. keep copying to it crashes (about 16386 words)
Actual Results:  
firefox disappeared (crashed)

Expected Results:  
reaching the limit
(Reporter)

Comment 1

13 years ago
alright.. i forgot to say, that i pasted the output from standard out/err.. 
(Reporter)

Comment 2

13 years ago
here is an example website, that makes your firefox crash:
http://aspx.dk/pub/public_upload/crash.html
(Reporter)

Comment 3

13 years ago
i got this error, when pasting data into the Tools->DOM Inspector->Text Field


*** loading the extensions datasource
/usr/libexec/mozilla-launcher: line 662: 19843 Segmentation fault      "$mozbin" "$@"
firefox-bin exited with non-zero status (139)
(Reporter)

Comment 4

13 years ago
alright, i tested it with the 1.5 and the crash site is working :)
but the CTRL+F field is still acting weird when getting tons of data.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060212 Firefox/1.6a1
I don't get either crash, but I can confirm the "weirdness" with the text fields: if nothing is selected, they'll display fine, but if you select a text range, all the text disappears until you unselect it, when it all appears again.
This is a symptom of bug #302294.

*** This bug has been marked as a duplicate of 302294 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: crashes when given large input in search field → Disappearing selected text in inputs when they're very full
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.