Navigating away after document.open triggers "ASSERTION: EndLoad called early" and "ASSERTION: More UnblockOnload() calls than BlockOnload() calls"

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({assertion, testcase})

Trunk
PowerPC
Mac OS X
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060209 Firefox/1.6a1

Steps to reproduce:
1. Load testcase.
2. Click a bookmark in your bookmarks toolbar, drag a file from the desktop, etc.

###!!! ASSERTION: EndLoad called early: 'mWriteState == eNotWriting || mWriteState == ePendingClose || mWriteState == eDocumentClosed', file /Users/admin/trunk/mozilla/content/html/document/src/nsHTMLDocument.cpp, line 1031

###!!! ASSERTION: More UnblockOnload() calls than BlockOnload() calls; dropping call: 'Not Reached', file /Users/admin/trunk/mozilla/content/base/src/nsDocument.cpp, line 5249
(Reporter)

Comment 1

13 years ago
Created attachment 211349 [details]
testcase (see comment 0)
(Reporter)

Comment 2

12 years ago
Bug 332896 involves the same assertions.
Jesse, do you still see this bug?  I can't seem to reproduce over here....
(Reporter)

Comment 4

11 years ago
I no longer see the assertion.  I noticed that the back button doesn't work after navigating away from this testcase; I filed bug 376064 on that.  Should this be retested once that bug is fixed?
Probably...  I dunno that that will get fixed any time soon, though.  :(  Especially since it's been a problem for at least two years, possibly more (I checked Jan 1, 2005 builds, which have the problem, then stopped).
(Reporter)

Comment 6

11 years ago
Ok, I'll mark this as WFM and leave a note to myself to check for assertions once bug 376064 is fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.