Closed Bug 326753 Opened 17 years ago Closed 17 years ago

Improve appearance of UI controls

Categories

(Firefox :: General, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 175279

People

(Reporter: pamg.bugs, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Buttons, drop-down list boxes, and other UI controls do not conform to the Mac UI standards.  Some parts (e.g., scroll bars) are nicely aqua, but others (checkboxes, combo boxes, butons...) are not, and are generally unattractive to a user used to pretty Mac applications.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox
2. Navigate to a page with assorted UI controls; e.g., https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox
3. Observe UI controls
4. Navigate to the same page in Safari

Actual Results:  
Firefox controls are different from, and not as attractive as, standard Mac controls.

Expected Results:  
Firefox controls should be (or at least look) identical to standard Mac UI elements.

*** This bug has been marked as a duplicate of 175279 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.