Closed Bug 3268 Opened 21 years ago Closed 21 years ago

{compat} NavQuirks behaviour for broken images

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED WONTFIX

People

(Reporter: elig, Assigned: buster)

References

()

Details

* TITLE/SUMMARY
ALT text for broken IMG tag drawn in 1x1 pixel rectangle.

* STEPS TO REPRODUCE
0) Launch Viewer
1) Open http://www.prometheus-music.com/gecko/imgaltfoo.html

* RESULT
 - What happened

A single gray pixel appears in lieu of the ALT text (equivalent to having set
width=1 and height=1). [URL is to a broken image.]

 - What was expected

ALT text to appear, encased in a box alongside a broken image bitmap, a la
Communicator 4.5.

* REGRESSION

 - Occurs On
        viewer (2.24.99 optimized build for Mac OS)
        viewer (2.24.99 optimized build for Win32 [NT 4, Service Pack 3])


 - Doesn't Occur On
        Communicator 4.51 (RTM build for Mac OS)
        viewer (2.23.99 optimized build for Linux; displayed as broken image,
covered in another bug.)

* HTML SNIPPET

<img src="http://www.prometheus-music.com/images/rw_foo.jpg" alt="eggplant">

* CONFIGURATIONS TESTED

- [Mac] Power Mac 8500/120 (233 Mhz 604e), 64 MB RAM (VM on; 1 MB of VM used),
1024x768 (Thousands of Colors), Mac OS 8.5.1

- [Win32] Vectra VL (233 Mhz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 Mhz P2), 96 MB RAM.
Component: Viewer App → ImageLib
QA Contact: 3853 → 1698
Assignee: rickg → pnunn
Status: NEW → ASSIGNED
Note. In "standard" (non-quirk) mode, the alt text should appear inline, not in a placeholder box at all. See bug 1990.
Target Milestone: M6
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Whiteboard: 4.28.99: Verification pending info on enabling quirk mode. (e-mailed rickg. no answer received)
Whiteboard: 4.28.99: Verification pending info on enabling quirk mode. (e-mailed rickg. no answer received) → 5.11.99: Verification pending info on enabling quirk mode. (e-mailed rickg. no answer received)
This bug is one of many related to alternate text of images. All these bugs
have been marked. To find related bugs, search the description field for the
string "[ALT]".
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Using the 5.13.99 builds, this is now recurring (both in Viewer & Apprunner) on
all 3 platforms.
Target Milestone: M6 → M8
Here is a comprehensive test page:
   http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/IMGalt2.html

Note. Is this really ImageLib? I would have thought it was Layout. I suggest
this bug be reassigned to Layout or Compositor.
Component: ImageLib → Layout
Whiteboard: 5.11.99: Verification pending info on enabling quirk mode. (e-mailed rickg. no answer received)
Agreed that component name was incorrect; moved to layout.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Priority: P2 → P3
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 1994 ***
Status: RESOLVED → REOPENED
Assignee: pnunn → kipp
Status: REOPENED → NEW
Re-opening [and actually reassigning to Kipp/M15.]

I'm specifically concerned that the scenario of viewing a page in Nav Quirks mode
is not covered in bug #1994.

If I've misunderstood the bug or the full relationship, please clarify.

Thanks!
Target Milestone: M8 → M15
Resolution: DUPLICATE → ---
What _is_ the scenario with viewing a page in NavQuirks mode?
Summary: ALT text for broken IMG tag drawn in 1x1 pixel rectangle. → {compat} NavQuirks behaviour for broken images
Target Milestone: M15
[Removing M15 marker as this bug is still being discussed]
My understanding was that upon encountering a broken image --- if Nav Quirks mode
is on --- the browser should be displaying the broken image + ALT text, rather
than just the ALT text inline.

Of course, I may be mistaken.
But why would we want to use broken image placeholder boxes in compat mode?

After all, the page is broken _anyway_, so its not like existing pages are
relying on this behaviour, is it?
Status: NEW → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → WONTFIX
it seems like there are a couple of issues going on here:

1. viewer mode: since we are not shipping viewer mode, this should not be an
issue.

2. quirks mode is not a feature and may not be in the branded release

3. alt ext in a wrapper, after some discussion from today, and based on what the
 spec states, alt text should appear inline and not in a wrapper

4. any img element pointing to a bogus image does not display the alt text,
rather a small dot -- this is an issue, but has been written up in another bug.

Since the original issue evolves around a) viewer and b) quirks mode, I'm
marking this bug wontfix. If quirks mode is introduced in apprunner, we can
reopen at that time.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.