Closed Bug 326935 Opened 14 years ago Closed 14 years ago

depress view toolbar button shifts everything below toolbar a pixel down

Categories

(Calendar :: Sunbird Only, defect, trivial)

x86
Windows 2000
defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: gekacheka, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060212 Mozilla Sunbird/0.3a1+

Depressing any of the view toolbar buttons (day view, week view, multiweek view, month view) shifts everything below the toolbar (most of the contents of the calendar window) a pixel downward, and everything shifts back up when the mouse button is released or the pointer is moved off the depressed toolbar button.

This does not happen for the other toolbar buttons.

(Problem may have appeared after changes made for bug 189416.)


Reproducible: Always

Steps to Reproduce:
Press down mouse button on any view toolbar button not currently selected.

Actual Results:  
Everything below toolbar shifts down a pixel or two.
(buttons to right also shift rightward a pixel or two.)

This does not occur if non-view toolbar buttons are depressed.


Expected Results:  
The button does not change size, so nothing changes position outside the button.

To see repeatedly, press mouse button down on any view toolbar button not currently selected, then while holding mouse button down, drag pointer out of button (say, into menubar), then back into same toolbar button.
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060212 Mozilla Sunbird/0.3a1+
with default toolbar and icons+text

What toolbar mode do you have?  Any extra icons added/removed?
I can confirm this on Windows 2000 with new profile.
Attached patch Patch v1Splinter Review
Apparently this is Windows only. So I only made changes to calendar.css for winstripe.
Attachment #216911 - Flags: first-review?(dmose)
(In reply to comment #3)
> Apparently this is Windows only. So I only made changes to calendar.css for
> winstripe.

I'm new to the project and no Linux user, so I don't know if Linux also uses winstripe. Maybe this patch is problematic for the view buttons in Sunbird for Linux.
Comment on attachment 216911 [details] [diff] [review]
Patch v1

(In reply to comment #4)
>> Apparently this is Windows only. So I only made changes to calendar.css for
>> winstripe.
> 
> I'm new to the project and no Linux user, so I don't know if Linux also uses
> winstripe. Maybe this patch is problematic for the view buttons in Sunbird for
> Linux.

Linux uses Winstripe in most instances. In some instances it uses a sub-theme called Gnomestripe. Therefore I agree that this should also be tested on Linux.

After testing this on Windows XP with the Luna theme, I can say that the patch works as advertised and I didn't notice any regressions.

Since this seems to be a low-risk polish fix, I would also vote that we take this for Sunbird 0.3a2.

Moving review-request to mvl, since he is the Sunbird owner.
Attachment #216911 - Flags: first-review?(dmose) → first-review?(mvl)
Comment on attachment 216911 [details] [diff] [review]
Patch v1

r=mvl, but not for 0.3a2. The shift of one pixel isn't a real high reward, and I want this to be tested on other OS-es (and versions of windows) before releasing it.
Attachment #216911 - Flags: first-review?(mvl) → first-review+
Whiteboard: [needs landing]
Patch checked in.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060905 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.