GIF animation buggy (jerky) with multiple CPUs

RESOLVED INCOMPLETE

Status

()

--
minor
RESOLVED INCOMPLETE
13 years ago
11 years ago

People

(Reporter: thewarden00, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Running an AMD A64-X2 dual core CPU.  All .gif animations display in jerks instead of a normal rate.  If I set the CPU affinity to just one processor (doesn't matter which) the problem goes away.  This may be related to other multi-threading issues.

Reproducible: Always

Steps to Reproduce:
1. Run Firefox
2. View GIF animation
3. Task Manager > Processes > right-click firefox.exe > affinity
4. Set affinity to any one CPU.

Actual Results:  
GIF animation started jerky, played smooth after affinity fix

Expected Results:  
Firefox should have displayed the image properly with multiple CPUs

Other programs (IE, ACDSee) render properly
Windows XP SP2

Updated

12 years ago
Summary: GIF animation buggy with multiple CPUs → GIF animation buggy (jerky) with multiple CPUs
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch

Comment 2

11 years ago
Gave reporter adequate time to respond. Resolving incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.