TextArea input does not honor Cocoa KeyBindings

VERIFIED DUPLICATE of bug 229473

Status

Camino Graveyard
HTML Form Controls
VERIFIED DUPLICATE of bug 229473
12 years ago
12 years ago

People

(Reporter: Brian Powell, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

The text input in Camino does not honor standard KeyBindings that all other Cocoa applications are bound by. This makes Camino odd to work with because the other text elements (address bar, google search, etc.) all honor the Keybindings; however, the textarea input does not.

Reproducible: Always

Steps to Reproduce:
1. Go to a page with a textarea
2. Type some text, press "CTL-A"
3. The cursor does not move to the beginning of the line.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 229473 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Requesting reopening of this bug:
This is different to and is not a duplicate of 229473


Text Input fields in Camino don't support custom keybindings in ~/Library/KeyBindings/DefaultKeyBinding.dict
or
/Library/KeyBindings/DefaultKeyBinding.dict

examples:
BBEdit http://hcs.harvard.edu/~jrus/Site/KeyBindings/BBEdit%20Bindings.dict Windows http://hcs.harvard.edu/~jrus/Site/KeyBindings/Windows%20Bindings.dict

more keybinding examples: http://hcs.harvard.edu/~jrus/Site/Cocoa%20Text%20System.html
(In reply to comment #2)
> Requesting reopening of this bug:
> This is different to and is not a duplicate of 229473
> 
> 
> Text Input fields in Camino don't support custom keybindings in
> ~/Library/KeyBindings/DefaultKeyBinding.dict
> or
> /Library/KeyBindings/DefaultKeyBinding.dict

That's bug 282097.
You need to log in before you can comment on or make changes to this bug.