Disallow elem.setAttribute("xmlns", "...")

RESOLVED DUPLICATE of bug 315805

Status

()

RESOLVED DUPLICATE of bug 315805
13 years ago
13 years ago

People

(Reporter: peterv, Assigned: peterv)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

13 years ago
We should disallow elem.setAttribute("xmlns", "..."), it leads to problems for serializing with duplicate attributes (even though they're in a separate namespace) when there is also an xmlns attribute in the http://www.w3.org/XML/1998/namespace namespace.
(Assignee)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 315805 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.