If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Image context menus missing if image declared by OBJECT tag

VERIFIED DUPLICATE of bug 22411

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 22411
18 years ago
9 years ago

People

(Reporter: Eli Goldberg, Assigned: Bill Law)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Image context menus missing if image declared by OBJECT tag

(Thanks to Matthew Thomas for identifying this scenario.)

* STEPS TO REPRODUCE
0) Launch Seamonkey
1) View http://www.jcinteractive.com/test/pnglive_ps5.html
2) Context click on a PNG image declared by an <OBJECT> tag.

* RESULT
 - What happened

The "Copy Image Location", "Save Image As..." and "View Image" context menu
items are not displayed.
(They're only displayed if the image is declared by an IMG tag.)

(There may be other differences that I missed.)

 - What was expected

Images declared through OBJECT of type image/* should be treated similarly to
images declared through the IMG
tag.

* REGRESSION

 - Occurs On
        Mac OS, Win32 & Linux Seamonkey (3.21.00 AM optimized beta 1 branch
commercial build)		

 - Doesn't Occur On
        IE 5.0 RTM (NT4 SP5 --- images are treated equivalently whether declared
by IMG or OBJECT)



* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Reporter)

Comment 1

18 years ago
CC:ing petersen, who I think is testing OBJECT tag.

---

Bill, Mr. Pinkerton thought you'd be the right person for this bug, so I've 
assigned it to you directly.
Target Milestone: ---
(Reporter)

Comment 2

18 years ago
[And, finally, sorry about the funky line wraps --- I've now properly configured 
BBEdit for soft wrapping.]

Updated

18 years ago
Target Milestone: --- → M20

Comment 3

18 years ago
Move to M21 target milestone.
Target Milestone: M20 → M21
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
(Assignee)

Comment 5

18 years ago
This bug is similar enough to 22411 so I'm reolving it as a dup.  I have a fix 
for that bug and it fixes <object type="image"> (syntax?) also.
Status: NEW → ASSIGNED

Comment 6

17 years ago
Image maps also do not work for images declared using object tags.
i don't seem to be seeing this --at least with the given URL... still a problem
for others...?
or, perhaps this just needed dup per law [sorry, missed that].

*** This bug has been marked as a duplicate of 22411 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
Those bugs don't look at all the same, but I'll take Law's word for it.

Verified worksforme, build 2001020513, Mac OS 9.0.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.