Last Comment Bug 327886 - tabbrowser depends on random menus in browser.xul
: tabbrowser depends on random menus in browser.xul
Status: RESOLVED INVALID
:
Product: Toolkit
Classification: Components
Component: XUL Widgets (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://lxr.mozilla.org/mozilla/source...
: 361489 (view as bug list)
Depends on: 339964
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-19 23:12 PST by :Mook
Modified: 2007-09-15 12:01 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Mook 2006-02-19 23:12:40 PST
(See URL)
If the elements menu_closeWindow and menu_close don't exist, setStripVisibilityTo() would throw.  Kinda hit me when using <tabbrowser> in my XulRunner app...

Would be nice if they fired an event instead of knowing about the surrounding XUL, but a temporary workaround would be to make it look before leaping (by making sure those elements exist)...

Workaround: make sure elements with those ids exist in the surrounding XUL.  They just have to be DOM elements, not even XUL :)
Comment 1 Nickolay_Ponomarev 2006-12-26 01:45:00 PST
(tabbrowser will likely be moved out of toolkit eventually - bug 339964)
Comment 2 Nickolay_Ponomarev 2006-12-26 01:45:30 PST
*** Bug 361489 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.