usbank.com - broken browser-sniffing and redirecting

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: Michael Bedworth, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If you use IE to go the HTTP://gettingthere.usbank.com it functions correctly while using firefox will end you up on a totaly different companies web page.

Reproducible: Always

Steps to Reproduce:
1.start firefox
2.enter url of : http://gettingthere.usbank.com
3.get wrong web page
It's not a *completely* different company - if you look at the bottom of the page at /AcctAccess/Logon.cfm where you are redirected while using IE, you'll see that BISYS is apparently the contractor or whatever that provides the services for US Bank. They just screwed up their redirection so that Firefox ends up on a generic page advertising them instead of at either the logon page or a page saying "sorry, we don't work with your choice of browser."
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: Gogin to the above url goes to a wrong company. This is for 401K plans through usbank. → usbank.com - broken browser-sniffing and redirecting
(Reporter)

Comment 2

12 years ago
this is true.  The reason I thought it was a firefox bug was because when I access the page via direct method or from the main usbank.com page firefox works with the page without issue.  I will report this issue to usbank.com also to see if they can fix it.
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> It's not a *completely* different company - if you look at the bottom of the
> page at /AcctAccess/Logon.cfm where you are redirected while using IE, you'll
> see that BISYS is apparently the contractor or whatever that provides the
> services for US Bank. They just screwed up their redirection so that Firefox
> ends up on a generic page advertising them instead of at either the logon page
> or a page saying "sorry, we don't work with your choice of browser."
> 

I am sorry.  You are correct I did not see that info originally.  Thank you for pointing it out.  Please see my comment #2.

Comment 4

11 years ago
It looks to me like this is fixed; I get the expected login page in both Camino-trunk and Firefox 2 now.

Comment 5

10 years ago
Marking FIXED per comment 4 and lack of any indications to the contrary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Blocks: 124594
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.