Crash when trying to create print preview [@ nsTableFrame::GetBorderPadding]

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Eugeny Pisarenko, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
All
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

It seems, firefox can't correctly render CSS instructions, agregated in both:
1) http://bestyle.ru/documents/styles/layout.css
2) http://bestyle.ru/documents/styles/print.css

Reproducible: Always

Steps to Reproduce:
1.File->Open http://bestyle.ru/documents/transform.php?xml=hosting/tech.xml&xsl=xsl/contract.xsl
2.File->Print Preview
3.

Actual Results:  
Particulary (on Windows 2003 Server, firefox 1.5.0.1 and  FreeBSD 5.3-RELEASE, mozilla 1.7.2) application close all the tabs and exit (without any prompts).


Look throught CSS.

Comment 1

12 years ago
I can confirm this Bug on
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

After opening Print Preview, Fx crashes.

Do you have any talkbackid? 

Updated

12 years ago
Keywords: crash

Comment 2

12 years ago
I have the same problem on Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.2) Gecko/20041016. It's seems to be an old bug. 

Comment 3

12 years ago
Two talkbacks:
TB15474010
TB15474011

nsTableFrame::GetBorderPadding  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 4012]
BasicTableLayoutStrategy::AssignPctColumnWidths  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/BasicTableLayoutStrategy.cpp, line 1451]
BasicTableLayoutStrategy::BalanceColumnWidths  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/BasicTableLayoutStrategy.cpp, line 245]
nsTableFrame::BalanceColumnWidths  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 3353]
nsTableFrame::ReflowTable  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 2127]
nsTableFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 1976]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsTableOuterFrame::OuterReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableOuterFrame.cpp, line 1315]
nsTableOuterFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableOuterFrame.cpp, line 1968]
nsBlockReflowContext::ReflowBlock  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3449]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2610]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsTableCellFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableCellFrame.cpp, line 858]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsTableRowFrame::ReflowChildren  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableRowFrame.cpp, line 964]
nsTableRowFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableRowFrame.cpp, line 1418]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsTableRowGroupFrame::ReflowChildren  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableRowGroupFrame.cpp, line 387]
nsTableRowGroupFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableRowGroupFrame.cpp, line 1239]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsTableFrame::ReflowChildren  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 3198]
nsTableFrame::ReflowTable  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 2139]
nsTableFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableFrame.cpp, line 1976]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsTableOuterFrame::OuterReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableOuterFrame.cpp, line 1315]
nsTableOuterFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/tables/nsTableOuterFrame.cpp, line 1968]
nsBlockReflowContext::ReflowBlock  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3449]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2610]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsBlockReflowContext::ReflowBlock  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 3449]
nsBlockFrame::ReflowLine  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2610]
nsBlockFrame::ReflowDirtyLines  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 2263]
nsBlockFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp, line 904]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsPageContentFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsPageContentFrame.cpp, line 103]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsPageFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsPageFrame.cpp, line 210]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsSimplePageSequenceFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsSimplePageSequence.cpp, line 405]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
nsHTMLScrollFrame::ReflowScrolledFrame  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 523]
nsHTMLScrollFrame::ReflowContents  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 571]
nsHTMLScrollFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp, line 769]
nsContainerFrame::ReflowChild  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp, line 904]
ViewportFrame::Reflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/generic/nsViewportFrame.cpp, line 240]
PresShell::InitialReflow  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 2866]
nsPrintEngine::ReflowPrintObject  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/printing/nsPrintEngine.cpp, line 2730]
nsPrintEngine::ReflowDocList  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/printing/nsPrintEngine.cpp, line 2498]
nsPrintEngine::SetupToPrintContent  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/printing/nsPrintEngine.cpp, line 2308]
nsPrintEngine::DocumentReadyForPrinting  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/printing/nsPrintEngine.cpp, line 2134]
DocumentViewerImpl::PrintPreview  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/layout/base/nsDocumentViewer.cpp, line 3418]
XPTC_InvokeByIndex  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2152]
XPC_WN_CallMethod  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1444]
js_Invoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1177]
js_InternalInvoke  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1274]
JS_CallFunctionValue  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line 4158]

Updated

12 years ago
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Summary: Crash when trying to create print preview. → Crash when trying to create print preview [@ nsTableFrame::GetBorderPadding]
Version: unspecified → 1.8 Branch

Comment 4

12 years ago
Can you guys test and see if this crashes in the most recent builds? I think it may have been fixed by (or is a duplicate of) bug 289517.

Recent builds: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Updated

12 years ago
OS: Windows Server 2003 → All
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> Can you guys test and see if this crashes in the most recent builds? I think it
> may have been fixed by (or is a duplicate of) bug 289517.
> 
> Recent builds:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
> 

I've tested on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20060222 Firefox/1.6a1. The bug still exists.

Comment 6

12 years ago
The frigging orderrowgroup blues, I am afraid that roc will not review this without removing that function. 

If you could create a minmized testcase and attach it to the bug it would really help.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 1.8 Branch → Trunk
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> If you could create a minmized testcase and attach it to the bug it would
> really help.

Ok. I'll try to help as much as possible.

Comment 8

12 years ago
Created attachment 213460 [details]
minmized testcase

Updated

12 years ago
Keywords: testcase

Updated

12 years ago
Blocks: 339130

Updated

12 years ago
No longer blocks: 339130

Comment 9

12 years ago
WFM with current trunk probably fixed by bug 347367.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTableFrame::GetBorderPadding]
You need to log in before you can comment on or make changes to this bug.