Closed Bug 32804 Opened 20 years ago Closed 20 years ago

Middle button doesn't work

Categories

(Core Graveyard :: Viewer App, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 6085

People

(Reporter: tapik, Assigned: rickg)

Details

I'm using XFree with /dev/gpmdata (gpm with repeater) and Genius NetMouse.
In NN4.7 the mouse middle button working properly, but in Mozilla M14 not.
what did you expect the middle button to do? new window? that feature is bug
6085, and though M14 didn't have it it is fixed on the tip (though not on the
beta branch for reasons I can't fathom). paste? Paste should work, although we
don't autocopy so you have to either be copying from somewhere else into mozilla
or use C-c to copy followed by a middle-click paste.

shaver is working on autocopy.
marking invalid, I'll reopen it if/when you say what was actually wrong (just
add some comments here). if it was open link in a new window, get the patch out
of the attachment to bug 6085, you can apply it without a recompile because it's
JavaScript only. just

cd ..../package/chrome/navigator/content/default
patch < patchName
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Target Milestone: ---
oh, and if it's X11-style copy and paste mark it as a dup of 7787 instead. We do
the paste side, but don't copy yet w/o control-c or the menu. there's a patch
shaver attached to 7787 yesterday that fixes that, but it's performance sucks
due to some bugs in the selection notify (that smfr thought wouldn't be too hard).
In Netscape 4.7 I can click with mouse middle button on the link and the new
window is opened with the link. But in mozilla M14 I can click with middle
button on the link, link is coming to be emphased, but no windows are opened.
It is my problem.
Thanks, opening new window by middle button is still working!
Please, add this path to the distribution :-)
Status: RESOLVED → VERIFIED
it is checked in to the tip but wasn't written in time for M14. I don't know if
the netscape commercial beta branch has it or not, I suspect no. But the mozilla
proper does.

reopening and marking as a dup of 6085.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 6085 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.