initial focus in "Update keychain with new information?" sheet

VERIFIED FIXED in Camino1.5

Status

Camino Graveyard
Accessibility
--
minor
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: the Falcon, Assigned: froodian (Ian Leue))

Tracking

({verified1.8.1})

unspecified
Camino1.5
PowerPC
Mac OS X
verified1.8.1

Details

Attachments

(3 attachments, 2 obsolete attachments)

41.47 KB, image/png
Details
28.83 KB, image/png
Details
7.66 KB, application/zip
Smokey Ardisson (offline for a while; not following bugs - do not email)
: review+
Mike Pinkerton (not reading bugmail)
: superreview+
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

The initial focus in the "Update keychain with new information?" sheet is on "Remember New Values", but it should rather be on "Keep Old Values", so that you can press Return to Remember New and press Space to Keep Old.

Reproducible: Always

Steps to Reproduce:
1. Go to a site that requires you to log in every time (that is, one that doesn't "remember" you) and for which you have a username and password in your keychain.
2. Try to login in with a different username.
Actual Results:  
"Update keychain with new information?" sheet appears with focus on Remember New Values.

Expected Results:  
Focus should be on Keep Old Values.
Again, since Esc works properly here, is this really an issue?  There's a 1-key solution for each option in a 2-button dialogue.
(Reporter)

Comment 2

11 years ago
It's just that there are visual cues/affordances that tell you what Enter and Space will do for any given dialog. Enter presses the default button, which is blue, and Space presses the widget that currently has focus, which is indicated by a blue halo. To me, Escape is the "Abort"/"Bail Out" key and in my mind maps to Cancel, which is not present in most (or even any?) sheets that Camino uses.
Having the focus initially on the default button is also not consistent with most Apple apps, by the way. Take TextEdit or Preview, for example. Open a file, do Save As and try to save it over another existing file. The following dialog appears:

<filename> already exists. Do you want to replace it?
<blah blah blah>
Cancel Replace

Here, Replace is the default button and the initial focus is on Cancel, which to me is the expected behavior: if there's more than one widget in a dialog, initial focus is consistently not be on the default button. (Yes, I have actually found some dialogs in OS X that are an exception to this rule, but "the exception proves the rule", you know.) Heck, even when I try to save a web page over an existing file with Camino, the behavior is exactly the same: Replace is the default, Cancel has the focus. I don't see why Camino's sheets need to be inconsistent with this.
(Assignee)

Comment 3

11 years ago
Created attachment 228015 [details]
New Keychain.nib

Per IRC, this behavior makes sense, especially since it defaults the "space focus" to the non-destructive "bail out" choice ("Don't Save" in the initial sheet, and "Keep Old Values" in the update sheet).

This also changes some of the terminology to match the pref in the Privacy prefpane, addresses bug 325880 comment 2, and brings it up to date with our nib standards.  Additionally, it maps the "Never Save for this Website" button to Cmd-N, which adds a nice bit of flavor for the keyboard geeks who try that sort of thing (ie me). ;)
Assignee: mikepinkerton → stridey
Status: UNCONFIRMED → ASSIGNED
Attachment #228015 - Flags: review?(alqahira)
(Assignee)

Comment 4

11 years ago
Created attachment 228016 [details]
Screenshot of initial sheet
(Assignee)

Comment 5

11 years ago
Created attachment 228017 [details]
Screenshot of update sheet
Comment on attachment 228015 [details]
New Keychain.nib

r=me

Mike, see comment 3 for a summary of the changes (some cosmetic, some behavioral).
Attachment #228015 - Flags: superreview?(mikepinkerton)
Attachment #228015 - Flags: review?(alqahira)
Attachment #228015 - Flags: review+
Blocks: 325880
Keywords: access
QA Contact: accessibility
Target Milestone: --- → Camino1.1

Comment 7

11 years ago
re: attachment 228016 [details], should that be a ’ in the "Don't Save" button ("smart" apostrophe)?
(Assignee)

Comment 8

11 years ago
Created attachment 228047 [details]
Same as last, but uses smart apostrophe

Yes.  Nice catch.
Attachment #228015 - Attachment is obsolete: true
Attachment #228047 - Flags: review?(alqahira)
Attachment #228015 - Flags: superreview?(mikepinkerton)
Comment on attachment 228047 [details]
Same as last, but uses smart apostrophe

You told me you fixed that :P

The buttons are only 11px apart in the main sheet now.
Attachment #228047 - Flags: review?(alqahira) → review-
(Assignee)

Comment 10

11 years ago
Created attachment 228087 [details]
More betterer

Sorry, miscommunication (I think I thought you were asking about the "Never save" quotes).  Fixes 11 px dealy. I could have sworn I checked that... :/
Attachment #228047 - Attachment is obsolete: true
Attachment #228087 - Flags: review?(alqahira)
Comment on attachment 228087 [details]
More betterer

r=me again.

Mike, see comment 3 for a summary of the changes (some cosmetic, some
behavioral).
Attachment #228087 - Flags: superreview?(mikepinkerton)
Attachment #228087 - Flags: review?(alqahira)
Attachment #228087 - Flags: review+
so this now defaults to "don't save" in the initial dialog? Why?
(Assignee)

Comment 13

11 years ago
The return key is still on "save", so for most users it still defaults to save, but the focus ring for FKA people defaults to "don't save," as the non-destructive "bail out" button.  This is relatively consistent across other apps (though it varies).
Comment on attachment 228087 [details]
More betterer

is don't save mapped to cmd-. or escape?

sr=pink
Attachment #228087 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 15

11 years ago
escape (but not cmd-.)
Whiteboard: [needs checkin]

Comment 16

11 years ago
Baking trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: access → fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [needs checkin]
(Assignee)

Updated

11 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

11 years ago
Keywords: fixed1.8.1 → verified1.8.1
You need to log in before you can comment on or make changes to this bug.