camino slower than FF to update SVG (change elements on mouse-over)

VERIFIED DUPLICATE of bug 324944

Status

Camino Graveyard
General
VERIFIED DUPLICATE of bug 324944
13 years ago
12 years ago

People

(Reporter: jonathan chetwynd, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060207 Camino/1.0rc1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060207 Camino/1.0rc1+

camino takes about a second whereas FF1.5 is almost instant, possibly 4-10 times faster.

Reproducible: Always

Steps to Reproduce:
1.mouse over links
2.
3.

Actual Results:  
border appears and text changes


I am attaching a file which is about 1/4 the size of the URI bit probably too large to immediately catch the issue.

sorry this isn't smaller, so this may remain a curiosity for a while...
(Reporter)

Comment 1

13 years ago
Created attachment 212588 [details]
demonstrates camino as slower than ff1.5
I do notice that we seem a little slower than Fx in updating color or word changes once moused-over, but it's almost unnoticeable (esp. on the larger SVG in the URL).  Simon, is this just our drawing and the opacity/fighting between Gecko and AppKit, or might this be an issue we should push up to to the Gecko folks about performance of SVG in embedding apps?
Summary: camino slower than FF to update SVG → camino slower than FF to update SVG (change elements on mouse-over)

Comment 3

13 years ago
When I profile, most of the time is spent in cairo (see bug 324944), but we may be drawing more than FF is becuase of the AppKit/widget and non-opaque views issues.
(Reporter)

Comment 4

12 years ago
Opera 9 is significantly quicker to load and more responsive for instance to onmouseover.

also see: https://bugzilla.mozilla.org/show_bug.cgi?id=324944

Comment 5

12 years ago
I can't see any difference between Camino and Firefox either, so duping this to bug 324944 based on comment 3.

*** This bug has been marked as a duplicate of 324944 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

12 years ago
cheers, apologies for not closing this myself...

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.