Download manager uses fade-in.

VERIFIED FIXED in mozilla1.9alpha8

Status

()

Toolkit
Downloads API
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Ray Allen, Assigned: sdwilsh)

Tracking

({polish})

Trunk
mozilla1.9alpha8
polish
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 +
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Download manager uses fade-in.  Users need to be able to see the download immediately.  The fade-in feature often does not show the download until after the download is completed.  This is a cosmetic problem but extremely annoying.

Reproducible: Always

Steps to Reproduce:
1. Right-click and "Save Link As" on any downloadable file of considerable size (e.g., 20megs+).
2. Wait for the download manager to show the download.
3. Continue to wait.
4. Download completes and download manager will finally show the download in the list.
(Reporter)

Comment 1

13 years ago
If there is a way to turn off this "feature", a setting should be added to Firefox Download Options.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
After clicking on a download link and clicking on the download dialog I see the download manager and its contents almost immediately, certainly in 1.5.0.1.
(Reporter)

Comment 3

13 years ago
It could be a problem that is easier to see on a slower pc.  Using an 800mhz celeron.  In any event, there isn't a reason for a fade-in feature in a download manager.

Comment 4

12 years ago
The fade-in itself is not a real problem, more a matter of personal taste. But you're probably experiencing bug 227260. dupe ?
(Reporter)

Comment 5

12 years ago
It could be a dupe as CPU usage does spike to nearly 100% until just after the fade-in completes.
(Assignee)

Updated

11 years ago
Assignee: nobody → sdwilsh
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox 3 alpha6
Version: unspecified → Trunk
(Assignee)

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

11 years ago
Flags: blocking-firefox3?
Target Milestone: Firefox 3 alpha6 → Firefox 3 beta1
This won't block, but we should revisit the design decision here. 
Flags: blocking-firefox3? → blocking-firefox3-
Keywords: polish
Whiteboard: [wanted-firefox3]
(Assignee)

Updated

11 years ago
Depends on: 388517
(Assignee)

Updated

11 years ago
Target Milestone: Firefox 3 M7 → Firefox 3 M8
URL is no longer resolving.
(Assignee)

Comment 8

11 years ago
(In reply to comment #7)
> URL is no longer resolving.
Not a big deal - going away with the UI rewrite.
(Assignee)

Comment 9

11 years ago
Fixed by Bug 388517.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007082805 Minefield/3.0a8pre
Status: RESOLVED → VERIFIED
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.